Excessively large numeric value in site settings causes emails not to be sent


#1

I checked my logs, I changed the setting ‘delete_digest_email_after_days’ from 9999 to 99999999 (to disable this feature) in 2016, this was the same day that the digest emails stopped sending.

I have since noticed the setting ‘suppress_digest_email_after_days’ was set to 0, this change does not show in my logs - so not sure how or when it was set. I just recently set it to the maximum value allowed in the admin settings (2000000000). No digest emails have been sent since (4 days ago), even though there are lots of accounts that have digest enabled and fit the inactivity requirements to be emailed. All other emails are sending fine.

One other setting I have enabled (also changed 4 days ago) is suppressed categories, I have 10 disabled, there are several other active categories though. Not sure if I need to wait longer for it to start working again, my values are too high or there is a bug.

Would appreciate help :slight_smile:

Edit: Here are my mailing list mode options - has not been changed for a very long time. I read in another post that disabling mailing list mode fixed digest emails not sending for some users.


#2

Update: After setting ‘suppress_digest_email_after_days’ to 9999 digest emails have started sending again.


(Jeff Atwood) #3

I think you might have exceeded the allowable integer value by setting it so high.


#4

Seems like it, but according to the emails logs now it seems like users are getting duplicate digest emails in the same day (with weekly digest setting). Have about 5x as many sidekiq jobs queued as needed. Running the latest version of discourse. Is there a way to temporarily pause the emails in the meantime while figuring this out?

EDIT: Solved - Just set ‘suppress_digest_email_after_days’ to 0 to clear out the queued sidekiq tasks, then set it back to 9999 and seems to be fine (won’t know 100% until the next batch of digest emails go out).


(Jeff Atwood) #5