External SSO activated, can't revert it :-(


I wanted to activate SSO to use discourse as an SSO provider for Mediawiki, but it looks like I’ve activated external SSO for discourse itself :frowning:

I’ve read oother threads describing workarounds, but they don’t work:

  • SiteSettings.enable_sso=false through ruby console -> login form displays “unknown error” upon submission of user/password
  • use backdoor /users/admin-login -> blank screen with “[“BAD CSRF”]” after submiting the form
  • selecting “resend password” in login form displays a 403 error in the dialog box upon submission

As I’ve logged out as admin (deleted all my cookies), I can’t access /logs to see if there’s some hint to be found there

So … anything I could do the regain access to my site ?

Many thanks

1 Like

You can disable SSO from the rails console or use the admin login path. Both are documented here on Meta if you use the search.

that’s what I did, but it still doesn’t work !
or is there another besides the ones I’ve listed in my original post ?

Correction, because I saw a typo: SiteSetting.enable_sso (no s in Setting !)

and finally : SiteSetting.enable_local_logins = true also didn’t help

Try https://<yoursiteurl>/u/admin-login/

/u seems to be an alias to /users :frowning:

How was this instance installed? What version is it?

docker container
2 days ago it was reported to be up to date in the admin panel (as I have no access to it I can’t cehck the version)

Problem worked around by restoring from a previous backup. Still no idea what went wrong :frowning: but at least I have gained back access to my site


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.