Facebook login not working 2020

The error it gives is this:

Can't Load URL: The domain of this URL isn't included in the app's domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings

The app domain is set in the settings for the site. Its not on a subdomain and the site is using https. I have even setup the www just in case under the settings.

Looking into it, I see that under Products, Facebook logins settings, not only is enforce https forced to on, but this also:

Use Strict Mode for Redirect URIs Only allow redirects that use the Facebook SDK or that exactly match the Valid OAuth Redirect URIs. Strongly recommended.

This setting can not be changed to off as I read other places to fix this now. Adding the domain there, throws a failed error that the redirect URI is not whitelisted and matching.

What would the redirect be for discourse for both creating an account and login to an account?

1 Like

What is the exact value for redirect URI you set on the Facebook login settings?

1 Like

Under the instructions I found on here I didnt see any example for the client oauth settings. for now I set it as https://examplesite.com/ to see if it would work or throw an error. I created an account here trying to catch the full redirect url but wasnt able to catch it. Im not certain what it needs to be for this to work on both login and creating an account.

1 Like

There was no option to turn off the setting.

Er what? The instructions are quite clear

Setup the Valid OAuth redirect URI field, entering https://discourse.example.com/auth/facebook/callback – obviously, replacing the domain with your site’s actual domain name and matching the HTTPS protocol.


Hmm actually I copied and pasted that from the page. But didnt realize where it went in setup. I did see it but it didnt save I guess. I’ll try it now. Thanks

1 Like

Working perfect. I must have not saved it after I guess. Thanks.