Fast edit doesn't work on content with certain characters

Well, I’ve been using fast edits for a while, but I think this is the first time I encounter this.

I edited a word, and it worked. I edited another, it didn’t. I tried multiple times, waiting several seconds between each. I reloaded the page, and tried it again, with no success.
No error in the javascript console. No error in the network tab as far as I know. No error in Discourse’s logs.

A regular edit worked, though.

(I suggest you watch the video in fullscreen)

Sorry that I couldn’t have more info about that and I couldn’t repro either. I didn’t think about trying in safe mode either… But I guess it’s worth more than nothing to have a testimony that the fast edit didn’t work in at least a case if other people encounter the same issue in the future and can investigate further.


Yep :wink: I know about this and I also knew it would probably come from a French :smiley: It’s related to quotes I think, I need to dig this, will keep this topic as a reminder :+1:


I think it failed when a “french single quote” is selected (I can repro this with trying to fast edit s'agit for instance)

edit: oh… too slow! :sweat_smile:


Oh, cool. Let’s rename the title then. Great catch.

Another thing:


What do you think prevented the fast edit here? The É prepending the :?

Also, the red book emoji appears both in the editor and the preview editor, but not in the final message.
That’s a bit confusing, but another issue.


I think quotes can cause issues even when not in the selection.


Is original situation related to that?

Sorry wrong language, but you can figure out what and where… I tried do fast edit:

But I couldn’t because of markdown:

So there is no need to write french or use quotes, just plain * is enough.

Not a biggie and I can live with that.

1 Like

Yes I should fallback to composer in this case. I recently made a change to core which could make part of fast edit simpler, will try to dedicate some time for a round of improvement to this in next months.


I somehow made the typo “group’s” when I meant “groups” — the classic grocery-store sign “apostrophe to warn the reader that an ‘s’ is approaching”.

I selected the word and brought up the quick-edit box, removed the offending punctuation mark, hit save, and that seemed to work… but the post didn’t change.

1 Like

Here are some words to try to edit, for your convenience and amusement:






Experimenting a bit: it’s not just “you cant remove the apostrophe”. Select one of the apostrophe’d words[1] and try to add words, replace it with something different (including removing the punctuation mark) — anythings. It doesn’t seem to save.

(For what it’s worth, I’m using Firefox on Fedora Linux.)

  1. see what I did there? ↩︎

1 Like

Also seems true if you select whole phrases that happen to be mark’d with the dread punctuation. For example, the previous sentence — but you can edit this one just fine.

Hi @mattdm! :wave:

I believe this is the same issue reported here so I merged your topic with this one :slight_smile:

1 Like

Cool I have this prioritized, we will sort this quirk out in the next month.

Happens cause we automatically prettify some stuff such as ™ and hello's that changes hello's to hello’s.


Should be fixed by:

Can confirm working now on paragraphs that have single or double quotation marks and other characters.

Thank you for reporting :+1:


This topic was automatically closed after 2 days. New replies are no longer allowed.

I woke up to this today because when I’m writing I don’t see the difference between ”you doesn’t” and ”you don’t”. So I fix those when I see such errors

Like here and now you doesn’t correct me when I do such typos.

But I would fix, if quick edit would work. And it doesn’t.

Do we have some other similar bug going on now or do I remember wrong?

It should have been fixed by this commit, I think? Per this topic - Fast edit doesn't work on content with certain characters

If it’s regressed I’ll re-open and move these over. :+1:

Update: I’ve just tested it on your post, and it pulled up the fast edit box and allowed me to enter an edit, but on saving closed the modal and did not make any changes.

(I’ve moved the posts over to the original topic)