Firefox v110 on Galaxy A50 getting not supported messages

I am attempting to use various Discourse based forums on Firefox for Android v110 and none of them work, I just get a message saying change to a supported browser. Is Firefox mobile supported and if not why not? I am not prepared to use Chrome.


Posting from Firefox v110 on iOS.

What Android handset and OS version are you using.

Does the DiscourseHub app work?

1 Like

Posting this reply from Firefox for Android 110.0.1.

Are you running some non default setting or extension?


My devices are a Samsung Galaxy A50 running Android 11 and no non-standard extensions or settings. Firefox is 110.0.1. My normal Firefox has never been re-installed it has just been updated all along from a very early one. Tablet is an ACER B3-A50FHD running Android 12 with Firefox 110.0.1 I do not have the app installed and do not want to have to switch to a APP just to follow some forum or other. Firefox should just work.


They’re not asking you to switch. It’s a troubleshooting step. If the DiscourseHub app doesn’t work either it would indicate it’s more likely a device issue rather than a software issue.

An alternative would be to see if the same instances have the same issues in Chrome if you really don’t want to try with the app. :slight_smile:

Indeed, please don’t try to infer intent here.

If you’re unsure you can just ask!

1 Like

I have tried Chrome and it works and also currently Firefox Beta works but stable Firefox does not. I do not see any point in trying the APP as these other browsers work. I am not sure the Firefox Beta will continue to work though given the current state of the stable version.

I have checked the Discourse current statements on mobile browsers and it says only Safari for IOS and Chrome for Android are supported. This is a very restricted set of browser for a product to support.

By the way the suggestion to try the Discourse hub was worded in such a way as to infer I should use that if it worked. If that was not the intent then perhaps it should have been worded differently to suggest eliminating a device issue. Highly unlikely in my experience for a device to cause this kind of specific issue with a browser.


Firefox stable works on my Android phone, both as anon and a logged in user on this forum.

Since there is no clear reproduction steps, it’s tricky for us to track down what problem is happening on your device. Also, there are no other users complaining about a similar problem, and I know quite a few use Firefox for Android as their daily driver on mobile.

@supermathie is Discourse still working for you?

1 Like

Falco has that version running on Android and I’ve since verified it too from a test device.

Something is causing the problem, and as Firefox is working here it’s very likely not the problem.

I would suggest resetting Firefox back to basics and go from there.

That might help: I experienced the same trouble 2 weeks ago with firefox mobile. CPU and bandwith were overstressed on my DO droplet. There were also a security problem. The issue is fixed after a check of running processes to remove unwanted jobs and configuring correctly rules on firewall

110.0.1 (Build #2015933339), 43c570380+

Works for me fine.

@broadstairs does it work with a private tab with no add-ons?

For that matter, what add-ons do you have? For example, are you using noscript or a similar add-on?

This is a huge leap given it was worded only as a simple query:

Can you please check whether meta and work with Firefox on your device?

If not, please post a screenshot of the error.


Just tried and get the usual unsupported browser message.

What add-ons do you have installed?

Can you show us the about page from the browser?


1 Like