Font Awesome Icon Not Showing


#1

I’m not sure if I’m doing something wrong, but when editing the font awesome icons for some badges, they don’t show up. I am trying to add the fa-smile for the “First Emoji” and it’s blank/broken. Any ideas?


(Biscuit) #2

Try it without “fa-”

Not sure if that’s the answer, but that solved my problem when using Font Awesome icons in a theme.


#3

Thanks for your response! I probably should have mentioned what I had already tried. :woman_facepalming:t5:

I already tried

“fas fa-smile”
“fa-smile”
“smile”

I was thinking maybe I need to just upload it and link to it, but wondered what could be the cause of it not showing the normal way.


(Biscuit) #4

Okay. Just had a play. There’s no Font Awesome icon called “fa-smile” which is probably why it’s appearing blank. There is an icon called “fa-smile-o” and that worked when I tested it. I also tested fa-paw and that worked too.

Here’s a link to the icon names: Font Awesome Cheatsheet

Does it work for you now?


#5

Thanks, worked like a charm. I’ll save that cheatsheet.

I was using a different cheatsheet and it was for this smile: smile | Font Awesome


(Joffrey Jaffeux) #6