Formatting and accents in urls

Hello everyone! I’m having trouble formatting the url.

is being generated automatically in questions and adds accents.

ex: Dívidas - CashLandia

in the browser it looks like this: Dívidas - CashLandia

what I try to do is: Dívidas - CashLandia


1 Like

I had trouble understanding the issue, but copy-pasting the direct link helped me get it.

I think it’s not discourse’s fault tho, you should avoid special characters in category slugs

Keep the Dívidas category name, but use dividas as a category slug

Other wise, when the category slug is saved with the accent, it will be changed right away: image

1 Like

the category is this: Dívidas - CashLandia

however I realized after it was generated, the others I managed to edit, but it gave an error 404 when I was going to edit and this was the only one that doesn’t run out of the accent.

even the questions were being added with accents when I had them. but the questions were normal without touching anything now, I just cleared the cache. this category does not edit, it deletes

Change the site setting slug generation method to encoded if you want special chacacters in your URLs.


exactly that, I do not want and even so it generates with accents.
look how it is, the pattern is what i don’t understand

You will need to:

  1. Change the site setting slug generation method to encoded

  2. Refresh the page

  3. Go and edit the problematic category, change the slug to an ascii one

  4. Head back and revert the site setting change



I’ve had the same problem.

The slug generation method is set to ascii but I accidentally typed the slug with an accent. After that I couldn’t enter the edit page of the category.

In the end I fixed the problem entering the rails console and fixing the slug there.

It’s not totally Discourse fault since that depends on the user typing an accent when there shouldn’t be one. But it would be cool if the system checked if the slug typed has only ASCII characters if the slug generation method is set to ascii.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.