Freaky Bloomberg URL results in spurious "You have been logged out" error

Whenever I put the URL below into a post, Discourse throws a dialog telling me I’ve been logged out, and forces me to click a Refresh button. If I’m quick, I can click Cancel fast enough such that another dialog comes up, letting me Abandon the post. I was also able to click the Reply button quickly enough once, such that the post actually posted. But editing it now shows the same error.,computer%20peripheral%20equipment%2C%20and%20software.

Putting the URL in code text, as I’ve done here, prevents the problem from happening, but my first attempt to neuter it by removing the H from https made no difference.

This is in 2.6.0b1 and happens here on meta as well as on my site.

1 Like

That is strange. I was able to create a post on our sandbox site with that link. The post is here: Will adding this link to a post cause any issues? - Demo. Are there any differences between how I’ve added the link and how you are adding it? What browser and operating system are you using?

1 Like

I don’t think your URL has the trailing period that came with my original link (it wrapped down to the third line in the code text).

I’ll also note that yours is showing the URL, whereas when I managed to submit mine, I got the title of the page.

To find the URL in the wild, Google on “when was Kagi founded” and click the top URL to go to Bloomberg.

I’m using Brave in macOS 10.15.6 Catalina.

1 Like

I tried replicating using macOS 10.15.6 Catalina and Brave ‘Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)’ (fresh install, standard options, no additional plugins, etc.) and I can’t replicate the login problem either in the sandbox or on a local dev instance.


Hmm, could it have been fixed in 2.6.0beta2? It’s not happening to me now either here or on my site. Regardless, all’s fine now!

Kagi Inc - Company Profile and News - Bloomberg Markets.