iOS keeps logging users out when HTTPS site added via HTTP link


(Mattias Petter Johansson) #1

My forum (Patreon sign in) is hosted by discourse and the app seems to kick the user out constantly. I am forced to reconnect every single time I open the app, see screen recording:


(Slack-Moehrle) #2

I also am experiencing this. I recently turned on https for our discourse site so I thought that might have something to do with it, but it does work maybe 1 out of 50 times I have tried. I get into the forums. Next entry into the app I have to authorize again and it goes back to re-prompting over and over to authorize again.


(Joffrey Jaffeux) #3

Any chance you can tell me when you started experiencing this please?


(Michael Brown) #4

That’s interesting - the same situation happens with @mpj - you’ll notice that it tries to load the site via HTTP first then gets redirected to HTTPS.

If you instead add the site as HTTPS does that resolve the problem?


(Slack-Moehrle) #5

so far, yes. I’ll keep trying throughout today, quitting the app, going back in, restarting my phone, etc.

Edit: After several hours of testing off an on, it appears that this fixed my issue.
Note: I had switched from http to https last week and uses an nginx rule to direct http to https.


(Sam Saffron) #6

Yes we got to fix this then … this is magic https handling we have that needs fixing.


(Mattias Petter Johansson) #8

Good to hear that it’s recognized as an issue. I’ll hold off promoting the app to my members for now.


(Mattias Petter Johansson) #9

I understand software development is complex, but is there any hope of having this fixed soon? A working app is, after all, one of the selling points for the discourse hosting.


(Jeff Atwood) #10

You have a lot of users entering the site as http://example.com instead of https://example.com in the app?


(Mattias Petter Johansson) #12

Oh, is that why it doesn’t work? Which one should they use?

edit: I just went through the flow - I would imagine that they most natural way for them to act when adding it in the app would be to type “funfunforum.com” into the app, which I’ve set up as 301 redirect to https://www.funfunforum.com via my registrar. (www.funfunforum.com is the CNAME record pointing to funfunforum.hosted-by-discourse.com.)


(Joffrey Jaffeux) #13

I will try to make an iOS release next week (at least submit the build).


(Joffrey Jaffeux) #14

I have had an issue not related to this one preventing me from submitting build friday, still on it.


Unknown Error when logging in on iOS app
(Joffrey Jaffeux) #15

Quick update for anyone following this, I have uploaded a build to apple and sent a test build to @mpj so he can try it


(Mattias Petter Johansson) #16

@joffreyjaffeux Hi joffrey! I’ve tried the new app and the issue unfortunately remains. Screen capture:
https://photos.app.goo.gl/z8HrO1Tf8WSz4quh2


(Joffrey Jaffeux) #17

Ok thanks for trying and the video. I will find a way :stuck_out_tongue:


(Joffrey Jaffeux) #18

Pushed an update which should work :crossed_fingers:


(Mattias Petter Johansson) #19

Unfortunately, it does not, for me. :frowning: New screencap:
Dropbox - Video 2018-06-04 12 34 37.mp4
Dropbox - Video 2018-06-04 12 34 37.mp4


(Joffrey Jaffeux) #20

can you try to uninstall the previous one before please ?


(Mattias Petter Johansson) #21

Okay, tried that. Problem still remains:

https://www.dropbox.com/s/tc30jelr81kkckb/Video%202018-06-04%2013%2000%2020.mp4?dl=0

I am going to PM you the password to that test account so that you can reliably replicate.


(Mattias Petter Johansson) #22

The latest version works!!!