Getting 'address not found' error trying to set up reply via email

Hi everyone,

I’m hoping I can get a little bit of help on this. I’m not supremely tech confident so I’m sure I’ve done something wrong on my end.

I’ve gone through this thread and I thought set it up correctly:

And tried a few things mentioned in some of the trouble shooting threads that I could find including enabling forwarding, allowing access to the Gmail account by signing out and then back in on a new browser, sending a test email to username+1234@gmail.com (that worked) and so on.

I’m getting the following message every time I try to reply to a PM email that we’re testing:

550 no mailbox by that name is currently available.

Here are all the error messages (as you can see I’ve been trying to figure this out for a while):

We set up a gmail address for the replies, I did make sure POP is enabled.

Since this is my first post, I’m only allowed to upload one image, but I have multiple screenshots of the setup I can send as well if that helps.

Beyond that, I’m just at a loss and can’t figure out where I missed something. It feels like it shouldn’t take 5 hours to figure this out! Any help would be greatly appreciated! Please let me know if you need more information.

2 Likes

I feel you. These sorts of problems can be very frustrating. As it happens, my own reply by email just stopped working though it had been working for months. Different symptoms from you, but anyway…

Do you have 2-factor authorization enabled on the gmail account you’re trying to use for replies?

1 Like

Thanks for the reply. I have that set as off in the gmail settings.

Check out Straightforward direct-delivery incoming mail. It makes things much easier.

1 Like

And do you have the “Less secure app access” enabled for that google account?

Link to the right settings page, here, but double check that you’re signed in to the right account when you get there.

Yup, less secure apps is enabled.

This one scares me, logging into the server might be above my paygrade. But will check this one. Thanks.

The tricky thing is that you’ll use discourse.example.com (or whatever your forum subdomain is) for the incoming mail address rather that the gmail address. As long as you don’t mess with your MX record(s) for example.com (and set MX for discourse.example.com) you won’t break anything.

If you’ve got a standard install, I’ll install and configure it for you for $150.

2 Likes

By the way, I meant to say before, you shouldn’t need any forwarding turned on in gmail. If you can setup the solution @pfaffman suggests, that would be great. I can’t because I’m not running my own server.

Sometimes it’s easier to just look at a screenshot and see if you notice anything out of place. These are the Discourse settings that were working for me.

1 Like

Here’s my setup:

Now looking at yours, I see I should switch the pop3 polling username to the gmail reply account it looks like.

Yes. I suspect that will fix it! Fingers crossed for you.

1 Like

Thanks, will follow up!

I’ll keep your link handy!!

1 Like

By the way, I think you also need to change your “reply by email address” to be the gmail address with “+%(reply_key)” just before the @.

1 Like

Will update that too, thank you!