Global rate API Limit is not working on live server

I had a problem with increasing the maximum number of users allowed in a discussion platform called Discourse. First, I set up Discourse on my own computer and successfully increased the limits for the number of users. I added 1000 to 7000 users using a script.

But when I tried to do the same thing on the live server hosted on Digital Ocean, I followed the steps to increase the limits in the configuration file and rebuild the app. Then, I started my script, but I encountered many errors with the code “429”. The global and admin limits didn’t work as expected.

I looked for help in these articles:

Article about available settings for global rate limits and throttling: Link
Please let me know your response as soon as you can.

Thank you

Do you have

  - "templates/web.ratelimited.template.yml"

in your yml? Try removing that.

There are no such limits.

Can you explain exactly what you changed and what you are trying to do that results in 429s?

1 Like

already do it but nothing works I am using only this files in templates section


  • “templates/postgres.template.yml”
  • “templates/redis.template.yml”
  • “templates/web.template.yml”

429 error means when you upload a bulk user from script to discourse using API then you get these error on the terminal because discourse have set a limit per minutes and seconds.

And limit override by discourse settings and some changes in app.yml files