Google Groups Import Script Fails (Due to Invalid Browser)

Hi Discourse Devs & Support,

As I mentioned in Importing mailing lists (mbox, Listserv, Google Groups, emails, ...), recently running the Google Groups import script didn’t allow me to log into my Google Account.

Repro steps:

  1. Run script with valid CLI options (the script never even gets to looking at the Google Group you specify, so the only important ones are a valid login to a Google Account)

After that, it says the script fails to login. I printed the last URL that the Selenium driver hit (when it is checking for successful login), and it ends up being this this error page which states that I’m not using an official browser and Google won’t log me in.

Definitely up for any workarounds, but it would ultimately block us from being able to proceed with a full migration to Discourse.

Thanks in advance!

1 Like

Any tips here @gerhard?

I’m not sure why, but I’m getting the same error when I run the script inside the Docker container. It works in my development environment though. I checked software versions and HTTP headers. Everything’s the same. Maybe some kind of countermeasure against automated logins?

You could try running the script in a development environment by following instructions like these: Beginners Guide to Install Discourse on Ubuntu for Development


The updated crawler for Google Groups should solve this. See Importing mailing lists (mbox, Listserv, Google Groups, emails, ...)