Google, Twitter and Facebook Logins not working due to ad blocker

Hello,

I’ve correctly setup Google, Twitter and Facebook logins for my Discourse instance, and a user can connect their account through the preferences page but for some reason they cannot create a new account using their Google, Twitter or Facebook account, why is this not working?

What do you mean “cannot”? Can you screenshot or describe what actually happens?

Isn’t there supposed to be a button in any of these places to use Twitter, Facebook and/or Google to login or create an account?

image
image

Yes, if you have setup Twitter and Facebook logins, there should be buttons for both of those options on the signup and login forms. Have you tried entering your site in safe mode? It is possible that a theme or a plugin is causing a problem with the buttons.

1 Like

Go To yourDomains/admin/site_settings/category/login
and enable twitter logins + enable facebook logins …

Just tried it in safemode and the buttons still don’t show up.

They are already enabled - like I said, users can connect their Twitter/Facebook/Google account but only once they sign up and go to their Preferences page.

Any ideas? I would like this as soon as possible.

EDIT: I just tried this on a different browser and it shows up as expected, any ideas why this doesn’t work on Chrome?

Do you have an ad/tracker blocker installed in chrome? See if the buttons appear once you disable it.

5 Likes

Interesting, it works now after disabling my Ad Block but this used to work on my previous installations of Discourse? I ran a couple other Discourse forums before and this would show up even with my Ad Block on? Maybe an update caused this?

Maybe an update to your ad block definitions are responsible.

8 Likes