Grammarly extension blocking Q&A commenting

Is it normal for the “Add a Comment” function to not work yet as the plugin is still in active development? I can’t seem to add comments. Is this like a current bug issue?


No, it should work. :slight_smile:

I’ve just had a run-through on my test site, and I’m getting some unusual results. There is a restriction where you can’t vote on your own post or comment:

However, it does seem to be getting muddled up and confusing my test user for the poster and not letting them vote/comment in some cases. I am not sure of the exact repro steps yet, but I think we should split this off into a #bug topic to investigate further. :+1:


Small update on this: After several confusing and misleading goose chases, the issue with mine is a browser-related one. :slight_smile: Specifically my Grammarly extension.

Do you have something similar that could be affecting yours @KhoiUSA?


Yeah, I do have Grammarly installed, thanks for pointing this out! It works now.


I just wanted to say me too! :slight_smile:

Gosh, I tried to think about all kinds of factors and I didn’t suspect that the cause would be a browser extension.


I was facing the same issue and was going to report a bug but then saw this topic. After turning off Grammarly, it worked fine. Given how ubiquitous Grammarly is now, this should actually be treated as a bug. There should be a workaround to fix it.

Perhaps we should contact Grammarly and bring the bug to their attention?

This could be the best workaround to fix it currently. Grammarly may be able to fix the bug, but for now disabling it is the best option.

1 Like