Granting custom badges is not working

Version 3.1.0.beta3
I’m trying to grant a custom badge using Web admin and the page just refreshes, but badge is not granted.

Granting badges via API still works.


Hi @md-misko. :wave:

I tried granting a custom badge on a couple of my test sites and I’m not able to reproduce that issue.

Try it with safe mode, to see if there is something in the theme causing an issue. :+1:


I uninstalled all plugins and used the safe mode with same results.

Did you grant the badge from the post or from /admin/users/id/username/badges? I can grant the badge directly from the post (where it is granted to the post owner) but I cannot grant it via admin console to an arbitrary user (with link to the post in Reason field).

1 Like

Thanks for the report @md-misko, our team has been able to reproduce this and we’re looking at it. We’ll let you know when a fix is out. :slight_smile:

1 Like

I think I may be getting the same issue: Grant a badge to individual users manually - #23 by spdegabrielle

This was fixed at FIX: Badge granting recursion error by davidtaylorhq · Pull Request #20750 · discourse/discourse · GitHub.

Please update to the latest version of Discourse. :slight_smile:


That’s right, I just upgraded, it works now!

Thank you!


This topic was automatically closed after 8 hours. New replies are no longer allowed.