Can't Grant Badge - Generic Error

pr-welcome

(Dylan Hunt) #1

When I try to grant a badge:

I used to be able to grant badges fine. Tons of people have this very badge – I tried to grant a random badge to myself, too, and still getting a vague error.

Nothing special about this badge - no sql or anything. It’s just a badge I manually add.


#2

Prob related to this: Badges no longer visible (1.9.0-b4)


(Sam Saffron) #3

Our error message can be TONS better here, so leaving this open.

But the problem here is that it is expecting a link to a post or topic per the text at the bottom.

There was also a bug in badges that was fixed, try latest


(Dylan Hunt) #4

Probably not this bug – I just found time to upgrade and it’s still doing it:

image


(Sam Saffron) #5

Wait, reason can not be “Backer!”, paste a link to a topic there or a topic id.


(Dylan Hunt) #6

That’s not for generic notes? Should really ask for a “topic url” instead of “reason”, if that’s the case. Super misleading~ Thanks, I’ll try it!

EDIT: Worked by leaving it blank.

image

Suggested changes:

  1. Change “reason” to “Topic URL”
  2. Catch “Sorry, an error has occurred” to “Invalid Topic URL”

EDIT 2: Oh, I just saw this –

image

Heheh… maybe a little bigger. Several people responded here not noticing, either.


(Sam Saffron) #9

#pr-welcome for improving the error message.


(Michael Howell) #10

I can’t reproduce this; it seems like Discourse just ignores invalid Reasons instead of producing an error…