Group flairs don't show

Sorry about the initial confusion! :sweat_smile: Thanks for the fix :tada:

1 Like

Thank you for reporting the bug here and thank you @nbianca for your work on fixing this.
The bug drove me crazy the whole day today. Hope to get rid of it soon!

1 Like

Is the fix live yet? And do we need to set flairs for each group again or it will be resolved after the update?

1 Like

Doesn’t seem to be solved yet.

2 Likes

Not yet, it will be merged probably first thing next week.

No, this should not be necessary. All flairs will be kept.

6 Likes

Hello, after updating to discourse 2.8.0.beta4

Icon image of the avatar disappeared and now when I upload the image again it is not saving

Please fix soon.

Nope, still not working.

Dear discourse team, the fix is not working. The behavior of setting a flair is the same - it disappears. No flairs are shown at forum anywhere either.

@nbianca

@magic007, @kinetiksoft the fix has been merged 17 hours ago. If you haven’t already done so in the last 17 hours, update to the latest version available.

If you are already on the latest version, what setting is there on Visibility?

1 Like

Well, I updated forum to the latest version and flairs are still missing.
I even upload new flairs for the group and set background color, and save. No changes, flairs are missing. Then I return back to group settings and uploaded flair is not there, background color field is empty.

Yes, its working now. :grinning:

It is showing same as screenshot.

@robotnjik what setting is there on Visibility?

Screen Shot 2021-08-10 at 3.29.41 PM

Currently only works if I set Visibility > Everyone. Other settings delete flair upload and bg color.

There was another merge about an hour ago, which may fix the issue:

Can someone please confirm if this fixes it in production?

Yes! The latest update fixed everything :smiley:.
Thank you all :heart:.

Now I wonder how mad guys at Visible flair for "invisible" groups: is that on purpose? will be, as it seems it was their fulfilled request that broke everything for everyone here :slight_smile:

Exactly, this is the second issue. You should take even this commit (just merged) REVERT “FIX: do not show private group flair on user avatars” by techAPJ · Pull Request #13991 · discourse/discourse (github.com) upgrading again the site.

4 Likes

I can confirm that this second fix has done the trick. All seems to be in working order :tada:

1 Like

Confirming it too. Now it works as expected.
Thank you!