Group owners can't add new members any more


#1

For group owners, the “Edit Group” button is not visible (next to “Members” and “Activity”). It looks like it is only shown for discourse administrators.

Therefore they can’t manage the group memberships anymore.


(Robin Ward) #2

I just tried to reproduce this but I can’t. I added a group owner (who is not staff) and was able to see the Edit Group button and add users. What version are you running?


#3

v1.7.0.beta11: Comparing 878af4c8b13fa550439476f1285767a098d5b020...tests-passed · discourse/discourse · GitHub

That’s weird. We also use SSO. Might that be related to it?

EDIT: I found the issue. Reloading the page with Ctrl+F5 fixed it. I’m not sure why, though. (I post the solution with an EDIT here, because the thread has been closed already…)

EDIT2: It fixes it only temporary. Whenever I go to the groups page, it still doesn’t show the “Edit Group” and “Protocol” buttons. I have to refresh the page with Ctrl+F5 every time first…


(Robin Ward) #4

I don’t think SSO would affect it. It is possible there was a regression that was fixed by the latest master. We are cutting a stable release in about an hour so you’ll be able to update and try again then!


(Jeff Atwood) #5