Handle upgrade failure properly


#1

Hi there,

I just tried to upgrade Discourse from 1.4.x to 1.5.1 and the upgrade failed at the rake multisite:migrate step with this error: MiniProfilerRails initialized twice. Set 'require: false' for rack-mini-profiler in your Gemfile

Now when I go to the dashboard, this is what I see:

I’m pretty sure I’m still running the 1.4 codebase and yet when I go to the upgrade page, it says I’m up-to-date. It looks like the upgrade process is getting confused when there is an unexpected error happening during the upgrade.

I realise there are two bug reports here but the second one seems more serious to me.


(Régis Hanol) #2

Are you running our recommended Docker install ? If so, have you tried the following?

cd /var/discourse
git pull
./launcher rebuild app

#3

Yes I’m running the Docker install.

I ran ./launcher rebuild app in the end and it fixed it somehow. It’s weird that I didn’t get the MiniProfilerRails error though… not sure what happened there.


(Régis Hanol) #4