Has anyone tried installing discourse on Apple's DTK?

Apple launched their Developer Transition Kit in the form of a Mac Mini powered by Apple Silicon with their A12Z chip a few months back. People have already reported it not being able to run applications like docker and chrome, but it holds promise in the long term for sure.

My question is, has anyone tried installing rails and discourse on it? This question is important because Apple is going to ship their new Macbook Pros and iMacs with their own silicon and although it being performant, might run into compatibility issues atleast initially.

This article show homebrew, zsh and ruby working fine.

Thoughts?

I think someone on the team may have one but I’m not sure if they can divulge anything at this point. They’ll have to chime in if they can.

I’m assuming at least at the outset development will need to be done in a VM until all the dependency issues are fixed.

2 Likes

I’m sure their production machines will have VM support but the DTK doesn’t.

Wait – you mean what they showed in the keynote isn’t ready yet?? :wink:

They did say at WWDC they were going to ship built in VM support (a la Hyper-V on Windows 10), so I guess we’ll see how good that is when it arrives.

1 Like

The DTK isn’t for sale. They gave it to the devs(especially iOS devs) so they can learn how to port their apps etc. They’ll take the kits back. Their production stuff will be a 1000 times better for sure but will share issues caused by the hardware architecture IMO.

VM support would be super cool though. Then comes the question of performance/snappyness for which we’ll absolutely need to wait for the product launch.

Oh I’m fully aware of this – I just assumed it would be closer to what they announced in June vs restricted. Was also being a bit silly! Sorry if that didn’t come across.

It will and I’d imagine our dependencies will have to compile for ARM first to make it usable. Probably best bet is to wait for a bit for anyone looking to develop on the machine.

1 Like

I have a DTK and tried a few weeks ago to run a Discourse dev environment on it, without success. There are currently two dependencies that don’t play nice yet, libffi and v8.

It’s very much possible I did something wrong in the setup, so I will try again soon. But don’t hold your breath, I suspect a fully functioning dev environment on an ARM macOS is at least a few months away.

4 Likes

Platform dependent gems I guess.

Yeah, chrome and vscode would need to work too :wink:

Also, thanks @pmusaraj @justin for your sharing your thoughts.

2 Likes

Has just been officially ported to ARM (might dust off my pi!)

2 Likes