Having polled topics only appear if a user wants to see them?

I have the plugin installed and working. Now I’m trying to get the configuration right for the visibility. Not everyone will be interested in the RSS feed posts so ideally i’d like them not to appear on the user’s homepage unless they elect to see them, I’ve disabled Embed unlisted to prevent posts appearing on the homepage but is it actually possible for individual users see them there if they want to? A user van check the sub-category or course, but that rather defeats the purpose of the feed providing regular updates.

The other issue is that I don’t want anthing from a feed appearing in the digest, which I can prevent by having the Embed unlisted option enabled. But then they’ll appear as Latest posts. That’s my dilemma.

Is there any other way to manage things that I’m missing?

Maybe you could have the RSS category as mute by default.

1 Like

I suppose users could mute the category if they’re not interested in seeing the posts from the feed. I’m trying to avoid an admin overhed for my members as it’s not a technical forum and they tend not to like a lot of playing around with settings.

Disabling the embed unlisted setting will not prevent the RSS posts from appearing on the homepage. There are some details about how that setting works in the OP: https://meta.discourse.org/t/configure-the-discourse-rss-polling-plugin/156387#prevent-embedded-topics-from-being-unlisted-3. That setting is somewhat confusing because it was added to solve a problem that can occur when Discourse comments are used on an external site. The setting doesn’t make a lot of sense when used with the RSS plugin. That is why the OP suggests disabling it.

I think for your case the best solution will be to disable the embed unlisted setting and follow @Jonathan5’s advice of publishing the topics to a category that is muted by default.

If you publish the RSS posts to their own category, you can add that category to your digest suppress categories setting to prevent the topics from showing up in the digest emails.


I’ve been testing the effect of Embed unlist. If I disable it, the RSS posts don’t appear in the list of Latest posts, which is the default page after logging in. That seems contrary to what your’re saying, but maybe I’m misunderstanding something.

Posts from the RSS feed are set to land in a dedicated category but I don’t want to disable it by default for two reasons.

  1. Users will have to actively select to enable it in their preferences, so it becomes an ‘opt-in’ feature that people may not bother with, which leads me to…

  2. New users won’t know to opt-in unless they’re given instructions in the welcome email and they miss that bit because they perhaps didn’t want to read it, they won’t even know about the feed.

I can see how these choices wouldn’t make sense on all forums but for the one I run (which has many older and non-technical usersI I believe it’s the best way. I’ve added a post in our ‘how-to’ section on muting categories so they can switch it off if they’re not interested in the content.

This I didn’t know and it exactly what I need - thanks!

1 Like

Possibly the issue you are running into is that if you are a staff user on the site, unlisted topics will still be displayed for you on the site’s Latest topics list. Regular users will not see unlisted topics on that page.


Just as a small note, unlisted topics can now also be seen by TL4 as well as mods and admin. :+1:


I use a normal account without admin privileges for testing changes for that very reason,


I’m having a change of heart about how RSS posts would be integrated. I was intending to let the news feeds (motorcycle sports) have free entry in to the forum and members would have to mute the sub-categories if they didn’t want to see them. Then I decided that automated posts runs contrary to the principle of users actively and willingly creating content that builds the community. So I’ll probably bring the feeds in as an optional benefit for members

I suppose my point is that feedback is always helpful and I appreciate the views of others here.


I got this working and set up how I want it on my staging server. This week I installed the plug-in on the production server, set everything up the same way, but I’m not getting anything appearing from the feed in the designated sub-category. The URL is definitely correct and providing updates - I copied it from the staging server polling settings and pasted it into a separate RSS reader. No problem there.

The plug-in is enabled.

Polling is set up. These settings have been saved. ‘trumpet’ is the renamed Discobot for the forum - I though I’d give him something to do. I used this successfully on the staging server.

The receiving sub-category exists with the following security settings.

I’ve muted the channel by default…

…and unmuted it for my user account (which also has admin privileges). I have a test account that’s just at Basic level and that isn’t seeing anything either, even after removing the default mute in the user tracking preferences.

I’ve run out of places to look as everything seems to be the same on both servers but only one is working. Am I missing something, or is there a log somewhere that may shed some light on what’s happening? The one thing I could try is setting up a second feed but that won’t explain why the first one isn’t working.

It’s strange it would work on one site, but not the other. Are you seeing any errors in the logs on the production site? You can access the error logs from Admin / Logs / Error Logs.

1 Like

There doesn’t seem to be anything in the error log that’s relevant to the plug-in. I’ll try adding a second feed to see if it’s conpletely non-functional. That may provide a clue. Other than that all I can think of is removing and reinstalling the plugin to set it up again.