Help changing domain

To be specific, I want to change the domain I use from discourse.jackril.space to jackrail.space.

But after adjusting app.yml and several rebuilds, I just get a 502 gateway not found and error messages:

2021/01/09 05:21:07 [crit] 4994#4994: *351 connect() to unix:/var/discourse/shared/standalone/nginx.http.sock failed (2: No such file or directory) while connecting to upstream, client: 59.167.198.231, server: jackrail.space, request: “GET /javascripts/workbox/workbox-routing.prod.js HTTP/1.1”, upstream: “http://unix:/var/discourse/shared/standalone/nginx.http.sock:/javascripts/workbox/workbox-routing.prod.js”, host: “jackrail.space”

from the nginx reverse proxy server, which worked find until this one relativelys small change.

Why is nginx.http.sock not being created? What is the correct procedure for changing the domain?

1 Like

In the /admin Dashboard, click on the button Change Domain Name. The first thing you get asked is to enter the new domain name, click next and follow the prompts.
image

I am self hosted. And now the site is completely inaccessible. Am I dead?

1 Like

No, Your installation isn’t dead. Did you follow this guide?

If so, the only additional steps required with an external nginx is to change the domain name in the nginx config and generate ssl for the new domain.

If you can’t get it up, it might be worth sharing what steps you took to rename discourse installation.

5 Likes

@itsbhanusharma Thank you. Issue solved.

4 Likes