Help! Problem with firewall/permissions and postgre?


This is my first official post as I usually just lurk and hunt for the answers, but this one is really stumping me. I recently updated our discourse after a bit via ssh and I’m having trouble getting the forum to connect to the internet and resolve the host. There are some issues with the postgres that I don’t really understand – getting the “not shut down cleanly” message in the FAQ of the PostgreSQL 12 update post.

There’s also an issue with docker (maybe?) that’s preventing me from starting the app and running as suggested.

This is the error that I’m getting with the postgres –

The source cluster was not shut down cleanly.

Failure, exiting



Please visit for support.

You can run ./launcher start app to restart your app in the meanwhile



Pups::ExecError: /root/upgrade_postgres failed with return #<Process::Status: pid 47 exit 1>

Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'

exec failed with the params "/root/upgrade_postgres"


** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.

./discourse-doctor may help diagnose the problem.

And when I try to start the app as suggested –

Unable to find image 'local_discourse/app:latest' locally

docker: Error response from daemon: pull access denied for local_discourse/app, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.

See 'docker run --help'.

Is there any way to fix this? I feel like I can’t fix the postgres without a running app, and I can’t figure out how to fix the docker/daemon/firewall issue

Have a look at PostgreSQL 13 update.

You need to rebuild a couple of times. Sometimes people just didn’t know to rebuild again and it worked. Sometimes (but not often) there’s something more difficult.

Worst case you can make a new install and restore the backup.

Thanks for responding! I have tried rebuilding multiple times, and it’s still failing with the same errors. tbh, I inherited this from someone else, so I’m kind of fumbling around in the dark over here.

I tried backing up via ssh using ./launcher enter app and get another error:

root@newforum:/var/discourse# ./launcher enter app
Error: No such container: app

I definitely didn’t delete it because I don’t know how to do that. Any ideas?

1 Like

I’ve seen one upgrade where there was some permissions issue. I can’t remember quite how I fixed it. But maybe you can rename the backup postgres directory, start it back up, make a backup, then start with a fresh install and restore it.

1 Like