Hoow to setup Discourse on AAAA (IPv6)?


Please help me, how to setup Discourse to work on IPv6?

I’m install forum and when my domain have A record with IPv4, forum is work.

But when I’m delete A record and add AAAA, forum not work.

A and AAAA records are equally important when it comes to resolving DNS.

If it’s not working then take it up with your provider.

It’s not an discourse issue.

1 Like

No. I’m have test forum (on NodeBB) and was use my IPv4/IPv6 to him and forum worked. Only Discourse can’t work with IPv6. I don’t understand why…

How did you install discourse? Is it a standard install? Are you sure that your os and your browser both support ipv6?

All of the discourse hosting infrastructure runs on ipv6. It’s well supported. You likely have an os or networking issue.

You need to set both the A and AAAA records.

1 Like

I’m use this manual and forum worked if my domain have A record (IPv4).
When I’m change A to AAAA, forum not worked.
In other community CMS my AAAA record is work, I try is for the test.
I’m try restart server and Docker, not help :frowning:

Why? For example nodebb community worked if domain have only AAAA.

And my Discourse not work if I’m change subdomain.
Example when install I’m enter this hostname: 1.example.com
So now I want to use Discourse with 2 hostnames: 1.example.com and 2.example.com.
It’s not work. Discourse work only with one hostname: 1.example.com.

So you want an IPv6 only website? Interesting.

The server may need IPv4 connectivity to bootstrap, but having only the AAAA DNS entry should work just fine.

That is not supported indeed.

1 Like

OMG. My Discourse forum is now work with only AAAA record on domain.
I don’t khow what was problems, mayse it’s bug CloudFlare and Docker…

1 Like

Why it’s not supported? Mayse it’s work if setting multisite? Sorry for the stupped, it’s my first work with Discourse.