How can I reinstall Discourse? with Console errors


(Daffy Chu) #1

Hello,
Just today in the afternoon, I have encountered a 500 Internal Server Error whenever I try to go into a category

So then I thought, why not I try to reinstall my whole discourse forum again and see if it will work again (Thankfully the website is not public yet so I don’t have to worry about losing posts)
But, while I was trying to search for a post that mentions anything about this, I couldn’t find it.
So I was wondering if anyone know a way to properly reinstall discourse forum so that I will be able to start again from scratch?

Also, here is the console error that I found when doing inspect element on the site

EDIT: My server machine is a centos 7 Latest version
Any help would be appreciated
Thank you

  • DC

(Kane York) #2

There’s a problem with the static pages plugin. Remove it and try again.


(Daffy Chu) #3

After removing the plugin, I still get the same error and same log
Updated picture


(cpradio) #4

What other plugins do you have installed? Can you copy that part of your app.yml and paste it here?


(Daffy Chu) #5

Here’s my plugin part of the config
http://pastebin.com/vpGiGVT9
Could it be a plugin broke discourse because of the newest update? I saw an update mail but I didn’t press update, it seemed like it updated it by itself

Any help would be appreciated
Thank you

  • DC

(Joshua Rosenfeld) #6

Those plugins shouldn’t conflict, but there’s no harm in trying to remove all of them (just comment them out) and seeing if the site loads. If it does, add them back one at a time.

Also, did you rebuild the app after removing the static pages plugin from your yml?


(Daffy Chu) #7

Yes I did rebuild the app after removing static page plugin.
Right now, I’m trying out every single plugin to see which one is actually causing my website to have an error.
Because when I rebuild the config I had before, I can’t connect to the page for some reason, but when I removed all plugins I could.

-DC


(Daffy Chu) #8

Seems like its the quick message plugin that’s screwing my site up. Not sure what the cause is, it worked till yesterday when I started to have errors


(Joshua Rosenfeld) #9

I’d try posting in the Quick Messages #plugin thread. @angus might be able to help you more.


(Daffy Chu) #10

Oops, I made a mistake, it was the topic preview not quick message. So I removed that one and installed every plugin I had. And it’s working fine now.


(Joshua Rosenfeld) #11

Well, that’s another plugin by Angus, so I’d still recommend posting there. He’s typically very responsive to bug reports, and if the plugin is broken in the latest version, or conflicting with another plugin, I’d guess he’d want to know.


(Mittineague) #12

I know I’ve seen topics about CentOS problems.

Those issues have been resolved with version 7 ?


(Daffy Chu) #13

What were the issues you speak of?