Help! Tried to install a plugin and now my forum is missing


We are currently having an issue with our discourse forum. I was in the process of trying to add a plugin (which I have been able to do multiple times previously without issues) and for some reason when I went to check the success of the plugin addition, the forum was missing. We have tried restoring the forum from backups both done today and from 6/8 in hopes of restoring the forum. However, no matter what we try, nothing seems to work. I was hoping that maybe you have seen this type of issue in the past and might be able to point us in the right direction as to what needs to be done to get it set back up? I have reviewed the build process and nothing really jumped out as an error…so I am not entirely sure where to look. Any help would be appreciated, I am fairly new to discourse…so I not sure what the proper protocol is at this point.

Thank-You for any help you may be able to provide.

1 Like

Hello and welcome @Bryan_Spann :slight_smile:

Using the safe mode options ([YourSite]/safe-mode) can help you pinpoint where the issue may be coming from. Also inspecting the console for errors when you try and load the site can also be quite revealing (right click, Inspect, then look at the Console tab when you refresh your page). Your /logs can often have some good information in too. :+1:

When you install a plugin and perform a ./launcher rebuild app this will also update your site to the latest version, which (if it’s not the plugin itself) can sometimes cause conflicts with any existing custom code you may have in place. Using the methods above can often help you track down exactly what is causing the issue and allow you to turn it off or tweak it as needed.


Jammy! Thank-You for that suggestion…I disabled the theme I was using and selected another and we now have a forum…what is odd, I have not touched themes for quite a few weeks…it was only after uploading this plugin that the theme had an issue…could the plugin have altered the installed theme at all? we are going to go back through each of the components in the theme and remove them and add them back one at a time till we isolate the the specific component that is having the issue…I thank-you for the help, it is truly appreciated.


It sounds like it was the accompanying update that may have created a conflict with one of your custom pieces of code. Hopefully you’ll be able to track it down now the pressure is off a little. :slight_smile: :crossed_fingers:

1 Like

Have you managed to track it down yet @Bryan_Spann? :slight_smile: :crossed_fingers:

If not, we’ve had a couple of reports of similar where the use of Discourse.User in custom themes was the culprit, as that’s now been deprecated in favour of currentUser.

1 Like

Hey There Jammy,

It does look like something similar in nature is going on, on our end as well. I have one of my developers going back through the code and updating the deprecated functions/calls. We are looking to be back up and running Monday or Tuesday with the updates.

I truly appreciate you checking back in…very rarely do you see that level of response…in short…you are a rare bird my friend, keep it up!


Hey Bryan, a bit of extra info for you. As @JammyDodger mentioned, Discourse.User is not recommended, but we didn’t actually intend for it to break yesterday. I’ve just fixed things up, so if you update your forum to the latest tests-passed then things should start working again.

Instead of an error, you’ll see a warning in the browser console. You should still aim to track down where that’s coming from and update it - eventually we will be dropping support properly.