How come everything is suddently bigger/zoomed?

I had seen it few weeks earlier on meta. But now since our instances have been upgraded to 2.5.0, we too have everything zoomed/quite bigger. Am I missing a setting?

Can you share a screenshot of it?

1 Like

This is on a 4K display. Used to be about 85-90% of it before this upgrade.


Which browser are you using? Have you changed any browser font size settings?

We somewhat recently changed how our base font size works. Originally we had been setting it to a hardcoded value of 15px. Now it’s an em-based value, so if your browser’s font size is larger than the typical default (16px) it will also increase the text size in Discourse.


Using chrome with custom font size (20 - Large) to compensate for 4K. Although this was not a problem before this discourse build.

What do you suggest I do to get back to sane sizing? Btw - Chrome zoom to 90% makes the font better but ux element placements seem off.

In your user preferences ( there’s a text size option, selecting smaller should help.

The reason for the change was to better adhere to accessibility guidelines. For example, someone with vision issues might want to increase their browser’s font size. The expectation is that this would make font sizes larger for all content viewed in the browser. The way we had previously defined fonts ignored browser level font-size adjustments completely.


Thanks. That user preferences does help and I understand your reasoning for doing it. :+1:

Update : I see a “Smaller” setting. Maybe there can be a “Smallest” setting which is further 10% smaller than “Smaller” to mirror the “Largest” setting :slight_smile:


True, having the full range couldn’t hurt. I’ve added “smallest” here:

This will be available with your next upgrade.


Awesome - love the quick addition!! :+1: