How do I disable rate limiting from a single IP

Hi, I’m running into a problem where my main site is calling Discourse a lot (since I use Discourse SSO, and do the double-ignore blocking, and all that)… and hitting rate limits left and right. :frowning:

The good news is that the calling site lives on a fixed IP… so is there a way to globally whitelist all API requests from a specific IP, to never trigger rate limiting?

In fact, in general, is there any way to turn off all the rate limiting? I don’t let users have their own API keys so really, I just want my app to be able to call over to Discourse and do anything, any time. The rate limiting is just getting in the way right now.


Are you caching anything between requests?


I am, yeah. I implemented a local cache to keep track of Discourse member IDs as they relate to my site’s main IDs and I keep track of the last time I performed some actions so I don’t have to call the API unnecessarily.

But when my main site gets busy, there are a lot of members entering/exiting forums. And since I implemented the double-ignore to simulate blocking, my site has to make a series of API calls for everyone on someone’s block list. If one of my members has blocked 5 people, that can easily translate to 15-20 API calls.

1 Like

is the limit it sounds like you want to boost.

A better approach may be adding a plugin to add a sync_blocks endpoint so you only need 1 API call per list modification.


Cool, I don’t know these settings but I’ll investigate! Thank you for the tip.

1 Like