How to add dreamhost smtp in discourse


(Aravinthraj N) #1

how to add Dreamhost SMTP in discourse. I have a problem with mandrill and Dreamhost SMTP both not sending mail.


(Régis Hanol) #2

Can you show us what you changed in the app.yml file?

(don’t forget to remove passwords/api keys before posting it publicly)


(Aravinthraj N) #3


(Aravinthraj N) #4

main domain is wordpress . i have install discourse as sub domain in it

how to do
Handle your first authentication. (This message will go away once you'd validated your first SSO request)


(Régis Hanol) #5

You forgot to remove the “#” character in front of the lines you changed. If you don’t, then they will be considered as comments and will not be taken into account.


(Aravinthraj N) #6

omg :grimacing: thanks bro @zogstrip


(Aravinthraj N) #7

I removed “#” but it not sending mail


(Régis Hanol) #8

Did you rebuild the container?


(Aravinthraj N) #9

yes i did…


(Aravinthraj N) #10


(Jeff Atwood) #11

Yet again the comment character was not removed from the config lines.


(Aravinthraj N) #12

ok i thoughti should remove “#” that appear option (optional) text. let me do it. now i get it


(Aravinthraj N) #13

still its not sending mail.


can anyone tell port number is correct


(Aravinthraj N) #14

not working


(Matt Palmer) #15

That port should be correct. Have you rebuilt your Docker image?


(Aravinthraj N) #16

yes i rebuilt it… ./launcher rebuild app


(colin avolve) #17

a bit OT…

Pros and cons of using Dreamhost v Mandrill (if someone already has a mail server at Dreamhost)?


(Aravinthraj N) #18

DreamHost mail didn’t work. I use Zoho SMTP it works fine.


(Nkansah Rexford) #19

What config did you use? Mine isn’t working.