How to disable security check for force https or disable these emails?


(Ivan Rapekas) #1

Hi,

my forum installed in subfolder :hugs:. When I enable force https the lightbox for pictures does not work. The only one workaround I found is to disable force https option. I checked that 99% of traffic is encrypted except <1% of external pictures. I found this is ok for us.

After upgrade to 2.0.1 forum admins began receive emails with a warning about force https disabled on the forum.

Is any way to stop such security checks or send certain emails to admins? I cannot turn on this option due to compromise between security and usability.


(Vinoth Kannan) #2

You could override it in a custom plugin by setting check_force_https: false in below method


(Jeff Atwood) #3

Hmm, wouldn’t we be seeing a similar problem with our hosted subfolder installs if this was the case?

Can you clarify what this means? What do you mean “does not work”, specifically?


(Ivan Rapekas) #4

Our problem:
when force https is enabled, then lightbox black frame, which is shown on mouse hover, totally disappeared from any picture in forum posts.

For example, you cannot zoom the image to the screen. You are able to see the picture in original size by right-click the picture and open it in new browser tab.

Once you disable force https, the problem with pictures should go away.


(Ivan Rapekas) #5

Thank you, @vinothkannans! I will take note of this but I found this too hard for me at this time :slight_smile: