Broken CSS for solution


(Jano Suchal) #1

Hi there,

I am running Discourse version v1.8.0.beta8 +16 with Solved plugin 0.1, but the CSS seems to be broken. The icon is not green a the text is not aligned.

Any tips?


(David Taylor) #2

Do you have any CSS customisations on your site?

If it’s a public forum, can you share a link so we can have a look?


(Jano Suchal) #3

No CSS customizations I know of. I’ve made it public just for you Štát Overflow - platforma.slovensko.digital :slight_smile:

Thanks for the quick reply!


(David Taylor) #4

That is weird… it seems like the CSS from the plugin hasn’t been included at all…

How did you install the plugin? Are you using the standard docker-based install?


(Jano Suchal) #5

I just added the plugin in the app.yml

  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-solved.git

and rebuild the app. Worked ok until I upgraded the discourse via admin GUI. Yup. Running the standard docker installation.


(David Taylor) #6

That all looks fine, can you try rebuilding the site from the command line again:

/var/discourse/launcher rebuild app and see if the problem persists? It might be that the GUI upgrade got stuck when compiling the CSS.


(Jano Suchal) #7

Hmm, this fixed it. Will let you know if anything goes wrong after another upgrade from GUI.

Thanks!


(Jeff Atwood) #8