If you click a mailto: link, does it work for you?


(Jeff Atwood) #1

I’d like to collect some quick data since @jomaxro brought this up. Please click or tap the below link (it is not a malicious link in any way, don’t worry)

mailto:name@example.com

… and indicate in the poll below what happened afterward:

  • my email client opened
  • nothing happened

0 voters

Collecting data… it’s science! :woman_scientist:


(Kris) #2

So, my OS default email client opens (Apple Mail)… but I don’t actually use it. I avoid clicking mailto: links when I can and just copy & paste addresses into webmail. (That’s also why Contact the Discourse team | Discourse - Civilized Discussion has the email spelled out in addition to being a mailto link)


(David Taylor) #3

I’m exactly the same as Kris - the default mail clients open on macOS and iOS, neither of which I have configured.


(Luke S) #4

I’ve voted, but this is only on android/chrome/gmail. I also use Windows/Firefox & linux/Firefox. (Gmail in browser tab is my usual email setup) If I get different results, should I change my response?


(Joshua Rosenfeld) #5

I’m with Luke here. Works as expected on mobile (Android 9) opening the Gmail app. Does not work on desktop (Windows 10, Chrome) where I have it configured to open Gmail.


(Mittineague) #6

With iPad Safari just now, neither of the two poll choices. But I did get a message box that I assume would let me open the email client.


(Daniela) #7

:white_check_mark: Windows 10 + App for email pre-installed with Windows 10 (never used before, now configured for Google account)


#8

Wait, how did you get that choice? Are you using Chrome?

I wish I could click mailto links and get that pop up on my iPhone.


(Jeff Atwood) #9

That’s really weird since it works fine in my Windows 10 / Chrome, configured to Gmail. Screenshot proof:

Did you not click the little button in the address bar to enable it?


(Jeff Atwood) #10

I am unclear how you got that “create mail with” app selection dialog from Mobile Safari in iOS. I can’t get it to happen at all in iOS and all my searching indicates it’s not possible.


(Jace) #11

I think you get the popup if you don’t have a default mail client set.
This is the prompt I get in Windows(7)
image

I don’t think mailto links are very popular anymore. Easy target for spammers.


(Jeff Atwood) #12

Spam is effectively a solved problem, the recommendation to “obfuscate” email addresses on websites dates back to the year 2000. And we all know how well security by obscurity works… badly :wink:


(Jay Pfaffman) #13

It works for me in Chrome on Linux (and presumably on MacOS and Windows) because of Mailto: for Gmail™ - Chrome Web Store.


(Jeff Atwood) #14

No need, this is a built in function in Chrome on Windows and Mac at least. Per this help topic

  1. Open Gmail in Chrome and click the Protocol Handler icon in your browser’s address bar.

  2. When prompted to “Allow Gmail to open all email links?”, select “Use Gmail,” and click “Done.” Then you’re done! Skip steps 3-5.

  3. If you were unable to see the Protocol Handler icon overlapping-diamonds, click the Chrome menu icon chrome-menu-1 in the top right corner of your browser, and choose “Settings.”

  4. Click the “Show Advanced Settings” link at the bottom of the screen. Then click the “Content Settings” button under the “Privacy” header.

  5. In the pop-up window, scroll down to the “Handlers” section and click the “Manage Handlers” button. Then select Gmail from the mailto dropdown, click “Done,” and, well, you’re done!

NB: the “protocol handler” icon only shows if the page has a mailto link actively on it, I think.


(Mittineague) #15

That was while using Safari

TBH I don’t really know. I almost never use email and I never took any active steps to set up the Mail app. I did install the Outlook app so that I could access my old hotmail account from time to time. It might be that the Outlook app wiped some settings somewhere. I looked at General, Mail, Safari, and Outlook settings but did not see anything that looked related to opening an email client from a mailto link. I’m guessing the message box displayed because I have ever only sent emails from the opened Outlook app, never a mailto link.


(Jay Pfaffman) #16

Hmm. I wonder when that happened.

I had to then go to Gmail (and not my G-Suite gmail), reload the page, and then I could get the icon to set up the mailto. I almost gave in and re-enabled the extension.


#17

Sadly, I’ve gone so far as to uninstall the Mail app to try to stop it opening it up when clicking links.

So now clicking an email link offers to install the app from the App Store. So unhelpful.


(Kane York) #18

I think the summary here is: clicking a mailto link will almost always do something, even if that something isn’t what you wanted to happen.


(Robert McIntosh) #19

On a new machine, so many configurations not yet done, so when I first clicked the link I had the same as @awesomerobot and the default Apple Mail opened and needed configured.

I made the protocol switch to Gmail as you suggested, and now when I click the link nothing happens at all


(Joffrey Jaffeux) #20

You might have to open chrome://settings/handlers and then click on the 3 dots next to gmail and choose to make it as default.

It should 100% work after this. Agreed it’s quite complicated…