I'm trying to migrate an old discourse by creating a new discourse, but I'm having trouble

I’m trying to migrate an old discourse by creating a new discourse, but I’m having trouble.

Previous discourse version was 2.8.0.beta4 (d3779d4cf7).
It is not possible to upgrade the version of this, so I am trying to migrate by creating a new discourse.

However, the backup file created by the previous discourse will not be uploaded to the newly created discourse backup.

After checking these and other things, I found that the folder structure of the discourse backup file of the previous version and the folder structure of the latest version of the backup file are different. In particular, the structure of the uploads was different.

I knew that the upload could not be done due to this reason, and I tried to solve it, but I still can’t find a way.

When I tried to change the old discourse backup folder structure to the same form as the new one, the backup was imported. However, when I proceed with the backup, it fails.

The image below is the log when backup fails.

If anyone knows how to solve it, any help would be greatly appreciated.

Why not? What happens? You should be able to restore an older backup to a new Discourse. Sometimes a database issue or a plugin can interfere.

That’s not the case, so there must be something wrong.

Can you elaborate on the differences you’re seeing?

1 Like

If i remove the uploads folder from the backup folder and import it, it uploads normally and backs up. But the image doesn’t appear. If i include the uploads folder, it will not be imported. An error like the image below appears.

If i translate Korean into English, it’s ‘I’m sorry. An error occurred while uploading that file. Please try again.’

스크린샷 2022-07-22 오전 11.38.34

Looking at the folder structure, the previous version created a separate folder for each image file. However, the latest version contains all images in the 1X folder.

Left is the uploads folder structure from the previous version.
Right is the uploads folder structure for the latest version.
스크린샷 2022-07-22 오전 11.46.54

See Restore a backup from command line (which I believe will tell you how to restore from the command line). That will give you the full error message.

It’s hard to see in such a small image. Those numbered directories can originate from the fact that the forum was over 5 years or so old, since that was used back then.

But the restore is not failing because of the upload directory. It’s failing because your backup does not contain a database dump (dump.sql.gz). Is there anything in there besides the uploads directory?

1 Like

It was solved by performing backup import by excluding the uploads folder,
and then inserting the uploads folder directly into the server.
Thanks for your reply :slight_smile:

2 Likes