Image could not be loaded

After I upgraded to 2.9.0.beta7, I found some of my posts’ pictures could not be loaded. Looks like this:


Anyone found this problem?

I’m afraid the picture attachments will be deleted by discourse, any one tell me how to stop auto deletion of post attachments?

Hey there!

Were the pictures not able to load after you uploaded your posts? Have you tried on a different browser?
Also, see the following:

Hope that helps!

  1. It can display a lot of images of differents posts in different topics. Even other posts in the same topic can be loaded.
    But some pictures are not loadable in some specific post, all pictures in that post seems to be misdeleted.
    About 10 posts are influenced in my forum.

  2. Not because of the browser.

Just to rule it out, have you tried to ‘rebuild html’ from the post wrench for those posts?

After “rebuild html”, the picture is not empty, with size as specified like [690 x 152] but nothing there. If download that picture, it’s now renamed to be “transparent.png” with 1kb size and nothing in the picture.