Importing from phpBB3

import

(Gerhard Schlager) #83

Yes, sidekiq is doing all the hard work. The sidekiq command mentioned in the first post and the Ubuntu setup were wrong until a few minutes ago. You should start sidekiq with the following command in the development environment:

bundle exec sidekiq -q critical,4 -q default,2 -q low

#84

Okay evrything works now, i’m still a bit confused as of why sidekiq said there were no jobs and now i have the user list working… but now evrything is fine, worked nicely, thx again


(Alexander Wright) #85

Edit: I think it’s because I don’t have enough RAM configured on the host.

I’m having trouble installing the import container.

The Mariadb-server is failing to configure:

I, [2016-04-20T10:24:53.982102 #36]  INFO -- : > apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --force-yes -y nano libmariadbclient-dev mariadb-server
invoke-rc.d: policy-rc.d denied execution of stop.
dpkg: error processing package mariadb-server-10.1 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
mariadb-server depends on mariadb-server-10.1 (= 10.1.13+maria-1~trusty); however:
Package mariadb-server-10.1 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mariadb-server-10.1
mariadb-server`

(Gerhard Schlager) #86

Works for me, but my log output looks a little bit different…

I, [2016-04-20T10:54:56.380297 #36]  INFO -- : > apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y nano libmariadbclient-dev mariadb-server

I’ not sure why apt-get is using the following options on your host: -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --force-yes

I think this is what’s causing the error.


(Alexander Wright) #87

Ah, no. That was something I added to try and force the configuration. I get the same error with and without. Elsewhere, I’ve found reports that the configuration fails in low RAM environments.


(Gerhard Schlager) #88

If that’s the case, I guess you’ll need more RAM. :wink:
I never tested it on a system with less than 2GB of RAM.


(Alexander Wright) #89

I’m running on a 1GB Amazon instance. In general, it works pretty well, but I only have 10 users, infrequently posting. I’m trying to persuade people to convert from phpBB. The live version will have more resources!


(Miguel Dominguez) #90

The import from my phpbb3 instance was successful for the most part. There are a couple of issues I’m seeing.

  1. Hitting the hamburger menu -> users, all stats are zeroed out. Anyone seen this before? Going to a particular user’s summary page looks fine.
  2. I’m working from behind a corporate firewall and have set the proxy settings in the container yml. The default user icons are all blank. I’m assuming that discourse is trying to grab these from the web and is not utilizing our corporate proxy. Any idea where I need to set proxy info?

Thanks!


(Fionn Delahunty) #91

Hey,

For those of us who don’t have a working knowledge of docker might it be possible for someone to create a guide
that explains each step in detail ? Such as the one that was created for installing discourse?

For example, I have no absolutely no idea how to copy app.yml to import.yml and edit the list of templates.

I’m sorry if this seems like a really stupid question, but it’s currently withhold me from moving an old PHPBB forum to Discourse in attempt to breathe life into it.


(Jeff Atwood) #92

I believe @erlend_sh is working on hiring someone from the community to write a detailed Discourse import howto topic.


(Fionn Delahunty) #93

Cool, Great!

Any idea of a timeline or quick solution to get a forum converted?


(Jeff Atwood) #94

Yes, sign up for our business hosting plan at https://discourse.org/buy – migration is included if you commit to a year of hosting on the business plan. That is the fastest way.


(lxk ) #97
creating users
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/mysql2-0.4.4/lib/mysql2/client.rb:107:in `_query': Table 'phpbb.phpbb3_users' doesn't exist (Mysql2::Error)

I’ve got a few things imported in, but hitting a wall with users. Any clues?


(Gerhard Schlager) #98

Well, looks like the table phpbb3_users is missing. The table_prefix seems to be correct, otherwise it would fail to detect the version number. So, not sure what’s going on here. Nothing much I can do without further information.


(lxk ) #99

Thanks, a manual import provided a bit more detail to work with, turns out I had to change the engine on a few tables from InnoDB

It’s importing now


(Gerhard Schlager) #100

Interesting. The Docker based importer should handle that and convert everything to MyISAM. I’ll look into it…


(lxk ) #101

for what it’s worth they were backups created within phpbb, I put a few bits and pieces in the mariadb manually and re import_phpbb.sh it and seemed to work


(Stuart Whelan) #102

When I follow these instructions I get a weak key error for the mariadb-server repo…

I, [2016-05-31T06:31:34.754884 #21]  INFO -- : > apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xcbcb082a1bb943db
gpg: requesting key 1BB943DB from hkp server keyserver.ubuntu.com
gpg: key 1BB943DB: public key "MariaDB Package Signing Key <package-signing-key@mariadb.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
I, [2016-05-31T06:31:36.257546 #21]  INFO -- : Executing: /tmp/tmp.0QWKnvkxpA/gpg.1.sh --recv-keys
--keyserver
hkp://keyserver.ubuntu.com:80
0xcbcb082a1bb943db

I, [2016-05-31T06:31:36.257651 #21]  INFO -- : > apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y nano libmariadbclient-dev mariadb-server
W: http://nyc2.mirrors.digitalocean.com/mariadb/repo/10.1/ubuntu/dists/trusty/InRelease: Signature by key 199369E5404BD5FC7D2FE43BCBCB082A1BB943DB uses weak digest algorithm (SHA1)
E: Unable to correct problems, you have held broken packages.
I, [2016-05-31T06:31:40.276647 #21]  INFO -- : Get:1 http://nyc2.mirrors.digitalocean.com/mariadb/repo/10.1/ubuntu trusty InRelease [3,234 B]

(Gerhard Schlager) #103

That’s a known problem with the new Docker container. Should be fixed soon.


#104

How to install the migratepassword plugin on a docker based import?