Inconsistent notifications for users invited to messages


(Adam Capriola) #1

I’ve had a moderator on my forum notice this happen twice now:

  1. I create a message with Users A, B and C
  2. I invite User D to the message
  3. I invite User E to the message
  4. User E receives no notification (bubble or email) of new replies in the message unless User D is the one replying (and it’s a blue bubble notification, not green)

I have SSO enabled, which might be relevant, but I’m not sure — I used to temporarily disable SSO so I could invite users to messages and apparently it happened then too.


(Jeff Atwood) #2

Correct, User E only has the private / personal message set to “tracking”. I’ve seen this a lot. I consider it a bug @sam.


(Adam Capriola) #3

I’m still seeing something like this, though I don’t think my original report was accurate. Here are the current steps and behavior:

  1. I create a message between myself and User A.

  2. I invite User B to the message. They see a blue notification bubble instead of a green one. User B is only tracking the message (not watching).

  3. User B replies and I see a blue notification bubble instead of a green one.

  4. User B only receives notification of direct replies in the message (which makes for dubious communication when it’s normally anticipated they’ll receive notification of any new replies).


(Jeff Atwood) #4

As I said, this is usually because that participant has the PM set to “tracking” only instead of “watching”. Not a good default, definitely seen it before.


(TechnoBear) #5

The problem here seems to be that the default behaviour is different for addressees of the message and those invited.

I send a PM to MemberA, and that message is automatically set as “watching” for both of us, and we will receive notifications of all posts. That is, I believe, the behaviour most folk would expect from PMs.

However, if I invite MemberB to that discussion, it is only set to “Normal” for them, so they receive no notifications unless they’re @mentioned, or post a reply.

Yes, it’s possible to manually change the status of the PM, but I think most members expect all PM messages to behave the same way, and this behaviour is confusing. Unlike the moderators inbox, where it is possible to set it to “watching” by default, there is no such option for ordinary PMs.

Surely the default setting should be “watching” for both the initial participants and any invited participants?


(Jeff Atwood) #6

I have seen this before, do you have a consistent repro?


(TechnoBear) #7

Yes - it’s the default behaviour. Tested on our instance, which is still running 1.6.0.beta5 and @cpradio’s sandbox, which is on latest.

Any member I send a PM to is automatically set to “watching” that PM, whether they’ve replied or not. Any member subsequently invited to the PM is set to “normal” until they reply.


(Jeff Atwood) #8

@sam you should have a look at this.


(Sam Saffron) #9

I believe @techAPJ fixed something in this area recently, if its still an issue can you flag to reopen


(Sam Saffron) #10