Infinite scroll not working in "Latest" on Mobile


(Mr X) #1

I have a standard v2.1.0 beta 2 install and the “Latest” section on Mobile only shows a certain number of topics (the number set by the admin at the categories topics field). After those topics (our discourse default is 20 topics) a text field appears saying no more recent topics available to read.

If the user refreshes the browser window (Chrome and Firefox tested) then the infinite scroll start working as it should.

Any idea how to fix this and have the infinite loop working as default on “Latest” section?


(Gerhard Schlager) #2

We haven’t heard any complaints other than yours.

Do you see the same behaviour here on meta or on https://try.discourse.org/?

  • If you do: Is this an Android device with the latest version of Chrome? What’s the screen resolution?
  • If you don’t: Try disabling plugins and/or site customizations on your forum. See How to use Discourse Safe Mode

(Mr X) #3

Actually it has the same issue on all devices I’ve tried (Android Samsung 7, IPhone 7 and IPhone 8) on my installation. No problem whatsoever on meta discourse or other discourse forums on the web.

I’ll try the safe mode setting

@gerhard if you could open a PM convo with me I can send you my discourse link for reference


(Jay Pfaffman) #4

If your site is on the internet there’s little reason not to share the link here.


(Mr X) #5

The default lang is Spanish so press on the Categorias -> Recientes in order to reach what is Latest in English.


(Bhanu Sharma) #6

Infinite scroll on your site works fine for me.
I have scrolled down 5 - 6 times and it loads topics properly.

I wonder if your own internet connection or connectivity to your forum’s host is a problem?


(Mr X) #7

(removed the gif simulation as it got solved)


(Sam Saffron) #8

I can repro on iPhone, can you amend the header image so it’s the same height as the one here? Does that fix it?


(Mr X) #9

Did that. No change. Except the logo size I have no other mobile custom css. A refresh always solves the problem but that’s annoying as many users don’t know they have to refresh.


(Sam Saffron) #10

I can repro this on https://www.ketogenicforums.com which is a hosted forum of ours on my iPhone, @zogstrip can you have a look at this next week


(Jeff Atwood) #11

Is this based on logo image size oddness?


(Sam Saffron) #12

In ketogenic case it may be the advertising plugin, but it “feels” like the same issue


(Mr X) #14

I’m seeing this case of “limited” Latest topics in other discourse installs over the web. I think it might be helpful to find a solution to this issue from which some might suffer. I’m willing to contribute with funds in case required.


(Sam Saffron) #15

Funds are not required, we will get this fixed. You are just going to need to wait a few days. Feel free to remind us about this in 14 days if it is not fixed


(Régis Hanol) #16

Ok, this should now be fixed :pizza:

The issue was not related to the logo/header/internet connection speed. It was two subtle bugs in the server code.


(Régis Hanol) #17

This topic was automatically closed after 16 hours. New replies are no longer allowed.