Installation - stop after running two lines

Hi discourse,

I am setting up a discourse with dreamCompute (Ubuntu-18.04), following the official installation guide.

It doesn’t seem to install the docker. I have waited for an hour and it doesn’t proceed. I successfully installed discourse with dreamCompute before.

I quit the installation and run ./discourse-setup again

it shows this error. Can anyone help please?

Try rebooting. And maybe a

 dpkg --configure -a

if it’s still broken after reboot.

And it’s easier to read text than pictures of text. Next time paste the text between lines with three backticks like

your text here
1 Like

Hi @pfaffman

Thanks for your reply.

I rebooted the server and ran “cd /var/discourse” then “./discourse-setup”. I got this error.

bash: ./discourse-setup: No such file or directory

I ran ls and there’s only a “shared” folder and couldn’t find /discourse-setup.

I rebooted again. No response after I ran “dpkg --configure -a”. Same errors.

I tried to git clone the /var/discourse folder again. I got this error.

fatal: destination path '/var/discourse' already exists and is not an empty directory.

Hope it is enough info for my issue.

That’s very strange. You can try

rm -rf /var/discourse

before you try to clone it again.

Thanks for the quick reply!

I tried what you suggested. This time:

dpkg: error: dpkg frontend is locked by another process

Instead of using the same folder, I create a “var/discourse” and install discourse. It ran into the same error but “dpkg --configure -a” works this time and discourse is successfully installed.

It connects fine using the IP address, but not with the domain. Below is the message when trying to connect with my domain. Is it the problem from the server side?

# Your connection is not private

Attackers might be trying to steal your information from  ****  (for example, passwords, messages or credit cards). [Learn more](chrome-error://chromewebdata/#)


Help improve Safe Browsing by sending some [system information and page content](chrome-error://chromewebdata/#) to Google. [Privacy Policy](chrome-error://chromewebdata/#)

ReloadHide advanced normally uses encryption to protect your information. When Google Chrome tried to connect to this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

I ran ./discourse-doctor. This is the error I got at the end.

cp: cannot create regular file 'shared/standalone/log/var-log/NzM2OWE5M2Q2ZWY3MjJm.txt': No such file or directory
cp: cannot stat '/var/log/NzM2OWE5M2Q2ZWY3MjJm.txt': No such file or directory
The output of this program may be available at
You should inspect that file carefully before sharing the URL.

You can examine the output of this script with
LESS=-Ri less /tmp/discourse-debug.txt

It works fine now. I think there was some problem with the DNS server and they fixed it.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.