Installing Discourse using Portainer

I use Portainer to manage my Containers. I wanted to install Discourse in a new container but I’m unable to do so. If anyone can help me with this would be appreciated.

I read the GitHub File and tried to follow it but I was unable to run console commands as I have not created a container. So I created/cloned an image of Discourse in DockerHub and installed it through Portainer but when I run it says exited with error code 0.

Why is this unsupported install @rishabh? Portainer is just a Docker Control Panel.

Because they only support one installation type, which is in a clean VPS where all the modifications and scripts run without any issue. Anything else is a custom installation and they won’t support it as the ways to use containers is infinite.

To be able to install Discourse, you need to run the bootstrapping done via the launcher utility. If you can add scripts to Portainer it should be relatively easy to do. Or you can just install Discourse in a VPS and push the resulting container to see if that works.

Other way, which could be easier is to decouple everything and deploy them individually, this means (in no way a complete list):

  • PostgreSQL
  • Redis
  • Unicorns
  • Discourse
1 Like

Yes we have only one official install largely to allow our community to support it well. If we had more, it would be difficult for everyone to provide quality troubleshooting and setup advice.


What you’ll need to do is use ./launcher to build your container and then launch it with portainer, passing all of the environment variables needed.

See Can Discourse ship frequent Docker images that do not need to be bootstrapped? for more discussion.

The easy solution that you can get free help with is to follow the official install instructions. If you need help with portainer and have a budget you can ask in #marketplace or contact me. I’m not familiar with portainer, but have built containers to launch with other tools.

1 Like