Integrated Discourse with Wordpress but the URL to 'continue the discussion' doesn't work

wordpress

#1

Hey.

So installed the Wordpress plugin and configured it, so this where comments were this now appears below new posts:

But the link looks incomplete:

http://discourse.example.com/session/sso?return_path=

Here’s the config on WP:
(I have API key and URL to discourse set up)

Also the config field “published category” doesn’t populate (blank dropdown) so may suggest it’s not linked with Discourse.

Any ideas?

Cheers


(Steven Greco) #2

In your PHP.ini file do you have “allow_url_fopen” enabled. This was an issue for me at first. Some hosts have this turned off by default for security reasons.


#4

This was enabled and still no luck. Ideas anybody?


(Chad) #5

I’ve got the same problem, the published category drop down is blank. My posts are being published, but not to the category I want, ending up in Misc I believe.


(Adam Capriola) #6

Look at the custom fields for the post. What is the value for discourse_permalink? Also try disabling SSO.

(Relevant plugin file.)


(Chad) #7

Weird, I disabled my theme (Genesis framework/child theme) and the Published category went from drop down box to a text field. I entered the category I want and new posts are going where they should. I then re-enabled my theme and all is still as it should be. The only thing I can think of is that I viewed the wp-discourse options page on my iPad at one point. SSO was not enabled.


(Scott) #8

I had the same thing happening but also was not getting the posts published to the Discourse forum.

My fix … the “Discourse URL” in the plugin settings didn’t have the http:// before the URL. Something that has become a bad habit of mine. I used to always include the http even when I knew it wasn’t necessary but far too many apps, forms, web properties etc. have made people LAZY.

… Pops