Invalid or unexpected token (at browser-detect...)

Hi all,

I’m receiving some JS errors saying invalid or unexpected token, all coming from files that end in .gz.js

I had a look at this thread here: Stackpath (Formerly MaxCDN) - Invalid or Unexpected Token which suggests that the content-encoding header is missing, however it is present for those files and it shows Content-Encoding: br

What can I do to fix this?

Here’s the headers returned:

Are there any other headers missing here that’s causing this?

Thanks for any help you can provide.

Looks like your CDN is misconfigured. For example, should have a content encoding of gzip but the header is missing.

This error happened when I migrated from DigitalOcean Spaces to Backblaze.

It seems that the Content-Encoding metadata wasn’t transferred over when I copied over files from DigitalOcean Spaces to Backblaze.

So I decided to delete the assets folder in Backblaze.

Is there a way to force all of the assets to be reuploaded?

When I run rake s3:upload_assets, I see the following:

rake s3:upload_assets --verbose
Installing CORS rules...
Skipping: assets/discourse-57df4f51068d4926f4e9170d2001380eadd7942574a11a99540a7fb39a0d5933.js
Skipping: assets/
Skipping: assets/discourse-57df4f51068d4926f4e9170d2001380eadd7942574a11a99540a7fb39a0d5933.gz.js
Skipping: assets/vendor-01a1a73134b66697f73050c52550416a7a4ca1be2731823d24d3c3db03de62dc.js
Skipping: assets/
Skipping: assets/vendor-01a1a73134b66697f73050c52550416a7a4ca1be2731823d24d3c3db03de62dc.gz.js
Skipping: assets/admin-e9a41caf10a7034a459f1ea903e10fdf4b4521ccfc457f9a4eec9a2f202968d9.js
Skipping: assets/
Skipping: assets/admin-e9a41caf10a7034a459f1ea903e10fdf4b4521ccfc457f9a4eec9a2f202968d9.gz.js
Skipping: assets/wizard-2a333f23a04838384081055016eee4318c873ebc8188d13fa84c86b12deabd7a.js
Skipping: assets/
Skipping: assets/wizard-2a333f23a04838384081055016eee4318c873ebc8188d13fa84c86b12deabd7a.gz.js
Skipping: assets/test-support-9ed31303d935a668f483d777d27ba04733f5c99d518b1379b45b3959f53937ea.js
Skipping: assets/
Skipping: assets/test-support-9ed31303d935a668f483d777d27ba04733f5c99d518b1379b45b3959f53937ea.gz.js
Skipping: assets/
Skipping: assets/test-helpers-b76fd4fd8c6b418680cdb0cacdebb7946b25abec19237a0d15d174b01b3f36eb.js
Skipping: assets/
Skipping: assets/test-helpers-b76fd4fd8c6b418680cdb0cacdebb7946b25abec19237a0d15d174b01b3f36eb.gz.js
Skipping: assets/
Skipping: assets/test-site-settings-3e7fd4983053d4b7813cac2dce831768a7bc09d15e2d563b026a4a805ca4477e.js
Skipping: assets/
Skipping: assets/test-site-settings-3e7fd4983053d4b7813cac2dce831768a7bc09d15e2d563b026a4a805ca4477e.gz.js

How do I force it to reupload those assets into Backblaze?

A rebuild should re-upload all missing assets

Thanks – I ran a rebuild and it seems to be working properly now (after clearing cache)

Appreciate your help

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.