Invitation 'Accept' button not working

Enable it via console:

cd /var/discourse
./launcher enter app
rails c
SiteSetting.force_https = true
exit

So are these command taking the desired action, or are they making the setting visible in the UI? If the later, then it does not appear to have worked.

The former. Now we know for sure that force HTTPS is enabled on your site.

2 Likes

Did this fix your problem @Chris_Mullins? I am unclear how you got into this state, how did you set up Discourse? Is your site behind a proxy of some kind?

Thanks for checking. Still struggling. Seems as if it may be related to this issue:

Were you ever able to dispose of this issue?

Latest client try:

  • New Account signup
  • New email
  • New Firefox install

Results:

Server side:
Digital Ocean droplet, automated setup.

v2.4.0.beta4 +10

At one time I had this working. 1st invited user got in fine. At that point I must have done something to break.

Happy to let you in for a peek if desired.

These are changes that could be related? Or maybe don’t work the way I think they do…

I’m not sure, do you see anything there @dax? The error message isn’t great. It could be this recent problem related to duplicate user prefs in the database:

Do you see any relevant errors in /logs when logged in as an admin?

Nope.

@Chris_Mullins can you please send me an invite to dax@discourse.org?

We should wait until he checks /logs first as it could be the above error.

1 Like

Invite sent. And assistance much appreciated.

One thing just occurred to me as I was inviting Dax - I am not putting filling in any Group when I send the invite. Should I be adding them to a genpop group of some sort?

@Dax happy to make you admin if you can get in or share my creds if not.

Well, the invite link is in HTTPS, however I can’t accept the invite due a 500 error that I can see on the browser’s console

You definitely need to dig into your site logs at https://macrofab.wiki/logs to see what is happening.

Is there an export? Here is a screenshot.

Yes this is the same bug as above @dax as I suspected

Excellent. This solved the issue. I went to your Github repo to try to find an Issue to follow, but don’t see Issues there. Is it turned off?

It relates to older versions, and isn’t possible in new versions that I know of. The main piece of advice is to learn to check your /logs as soon as there is a problem.

1 Like