Is it impossible to remove Associated Accounts?

Hiya,

so after a bit of looking around I’ve found that there’s no easy way to remove associated accounts.

I’ve linked my Google account via the Associated accounts category under “account” in preferences, before you link anything, this is how it looks:

image

On my discourse site I have 2 “associated accounts”.

However when I go to my “preferences” tab there is no button to “remove them”.

Am I missing something here, or is there no way to remove associated accounts?

Thanks for any help in advance!

1 Like

What version of Discourse are you running?

You should be able to remove them, this has been possible for a while: Future Social Authentication Improvements

And here’s the code that controls it: discourse/managed_authenticator.rb at eb70ea44780ad6d31db82baec4845b6eb4b8e804 · discourse/discourse · GitHub

4 Likes

image

I didn’t even own a discourse website in 2019, I surely am past this update.

From which auth providers?

Is this happening with all of your users? Do you see any error in your browser’s console?

Discord & google.

I do get an error:
image

On my testing account it works completely fine.

But I still get the same error I got on my normal account.

image

(Testing account)

The 429 error is a rate limiting error. It is mostly likely caused by a misconfiguration of a reverse proxy.

You can confirm this is the isssue by checking user IP addresses and seeing that they are all the same (they are all the IP of the reverse proxy).

2 Likes

If I’m understanding you correctly, I checked & I can confirm this doesn’t seem to be the issue.

With the latest discourse update now installed it seems that error has disappeared, however I can still not access my associated accounts.

What happens when you click the red :wastebasket: button? Any logs in your browser or on the server at /logs?

1 Like

Doesn’t exist on my accounts view, on my alternate view the red button does work. On my main account I don’t even get the “associate accounts” table.

Do you have two-factor authentication enabled? Associated Accounts can’t be used alongside 2FA.

1 Like

I do indeed have 2FA enabled, my associated accounts are still inked.

Will I have to disable 2FA to remove them?

Via the user interface, yes you would have to disable 2fa.

If you’re the admin, and comfortable on the rails console, then you could run something like:

User.find_by_username("my-username").user_associated_accounts.destroy_all
1 Like

It’s a bit of a nuisance, but I will go ahead, thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.