Is this meant to happen when I run the rebuild command?


(Vaping Community) #1

I’m Running Discourse on a DigitalOcean Droplet

I had to change my email settings in app.yml which I figured out how to do just fine but when I try to run the rebuild container command I see this:

Is that normal? If I follow these prompts will it destroy my Discourse forum, I spent ages setting it up today and backups seem to be broken:

[2018-02-05 21:13:56] Marking backup as running...
[2018-02-05 21:13:56] Making sure '/var/www/discourse/tmp/backups/default/2018-02-05-211355' exists...
[2018-02-05 21:13:56] Making sure '/var/www/discourse/public/backups/default' exists...
[2018-02-05 21:13:56] Pausing sidekiq...
[2018-02-05 21:13:56] Backup process was cancelled!

I’m completely lost, thanks in advance


(Jay Pfaffman) #2

That doesn’t make any sense at all. I thought that their one-click install did something that resembled a supported install, and that you’d see a message like that when you first logged in, not when you ran ./launcher.

If that’s what ./launcher does, then you may be on your own, as this does not look like a supported install.

When did you install it?


(Vaping Community) #3

I used their one click install yesterday, even installed the Retort plugin without any issues, it let me rebuild it then but now it just goes to that message straight away. :confused:

EDIT: I have one error in the discourse admin logs.

TypeError: e.jqXHR.responseJSON.join is not a function
Url: http://www.vapingcommunity.co.uk/assets/application-2419cc98b7825aaca132b6a042338b1022877b8d183bb67ecd18f4b14525f307.js
Line: 5
Column: 24589
Window Location: http://www.vapingcommunity.co.uk/

(Vaping Community) #4

I have the option of taking a snapshot on Digital Ocean, do you think it would be worth a try to do that and go through the above prompts just to see what happens?


(Jay Pfaffman) #5

It usually prints that message when you log in and you can just control-c to quite and then

cd /var/discourse
./launcher rebuild app

I know some ways that I’d fix it, but none are simple enough to explain here.

But sure, take a snap shot and see if you can fix it. If things get really bad you can step back to the snapshot.


(Vaping Community) #6

Ill try that right now, thanks so much for your help


(Vaping Community) #7

You are a Legend… So here’s what I did.

Logged on via SSH

cd /var/discourse
./launcher rebuild app

The message came up, I used control-c and it just ran the rebuild :smile:

Thanks again, I was panicking as this is my second day using Discourse and doing anything command based. :+1:


(Vaping Community) #8

@pfaffman Sorry if this in the wrong place but can I just add that after the rebuild I tried a backup from the admin section, it failed but I got a solid error log and a notification:

[2018-02-05 23:05:17] Marking backup as running...
[2018-02-05 23:05:17] Making sure '/var/www/discourse/tmp/backups/default/2018-02-05-230517' exists...
[2018-02-05 23:05:17] Making sure '/var/www/discourse/public/backups/default' exists...
[2018-02-05 23:05:17] Pausing sidekiq...
[2018-02-05 23:05:17] Waiting for sidekiq to finish running jobs...
[2018-02-05 23:05:17] Backup process was cancelled!
[2018-02-05 23:05:17] Notifying 'vapingcommunity' of the end of the backup...
[2018-02-05 23:05:23] Removing old backups...
[2018-02-05 23:05:23] Cleaning stuff up...
[2018-02-05 23:05:23] Removing '.tar' leftovers...
[2018-02-05 23:05:23] Unpausing sidekiq...
[2018-02-05 23:05:23] Marking backup as finished...
[2018-02-05 23:05:23] Finished!

So can we assume that a rebuild somewhat fixed the backup process or changed it in some way?

These don’t exist in my screenshot?

Making sure '/var/www/discourse/tmp/backups/default/2018-02-05-230517' exists...
Making sure '/var/www/discourse/public/backups/default' exists...

Edit: Backup in the admin section worked!! :smiley: