Issue with displaying Forum on iPad (iOS 12)

I first discovered this issue on the Sketchup forum when using my iPad and later discovered it also exists on this forum. The upper part of the screen does not display although topics lower on the screen are visible. If you look at the screenshot, you can see what I am referring to. The banner at the very top of the page is also hidden.
When I say hidden, that’s exactly what is happening. If I scroll the visible items up the page, the banner will finally appear as if I raised a curtain. This problem does 't appear with any other web pages. Any suggestions? I am using Chrome but have tried other browsers as well.

It doesn’t happend for me and I’m using iPad all the time :flushed:

But mine is ordinary iPad and older 6th gen (updates ok), and I don’t know if there is any meaningful differences between Pro and normal one in this case.

Can it be somekind cache issue on device itself?

This only started yesterday for me. I am using an iPad Air which I believe is 1st generation. It is running iOS 12.5.5 which is up to date for that iPad. I’ve tried a forced restart, clearing the cache, and also tried other browsers. As I noted in my original post, I first noticed this when I was on the SketchUp forum which is hosted by Discourse. No other web pages act this way. This seems to suggest that a change was recently made by Discourse which affected how it behaved on older iOS hardware.
There was an earlier issue, back in March of this year, where the forum wouldn’t even load on legacy browsers. Support was able to remedy that issue. Perhaps someone can fix this one as well.

Has this resolved itself for you? I ask because I just tested this on my 7th Gen iPad, running iOS 15.3 and I’m not having any issues with it:

Sketchup on Firefox screenshot

Sketchup on Safari screenshot

Sketchup on Chrome screenshot

For good measure, I also tried meta and it was also working ok.

meta on Firefox


Thanks for the report @PdxRick, I can easily reproduce this issue on old iOS (iOS < 13) devices. Since we are still supporting those devices until January, we will take a look at this.


Thank you! Next year I suppose I’ll need to stick with my PC.

Here’s a fix for the issue:


An earlier version of this locked me out of a community for around three years when my iPad 2 was deemed too eldery to get support as the first instance I used switched to Discourse. It was only earlier this year that I had sufficient cash to buy a new iPad Air (4th gen).

And I’m now faced with Discourse, which is across half-a-dozen my new communities, being inaccessible from my still fucntioning iPhone 6S (limited to iOS 12). Not that it’s features are conducsive to my eyesight.

Are you sure about that? I’m pretty sure it’s possible to update the iPhone 6S to iOS 15. That should allow you to use Discourse for a very long time.

No I’m not. Am sure, because I checked with Settings > General > About that it is actually a 5S! My communities accesses would definitely stop in the New Year.

The issue appears to be fixed in this forum but still exists when I use the SketchUp forum. Will the fix be populated in other Discourse hosted forums?

thanks for the help. This issue has now been corrected on the SketchUp forum.

1 Like

Oh, okay. That makes more sense. The iPhone 5S is stuck on iOS 12.