Issue with Publish to Category topic timer

I’ve followed these instructions, but things are not working. I have a couple of issues here.

I only want some user groups to see the topic (let’s call them “GroupB”). So I’m trying to publish the topic on Monday to a category that “GroupB” has access to.

If I publish the topic to a private category… that GroupB doesn’t have access to – then I must remove GroupB from access to that topic. (else it won’t save - because GroupB doesn’t have access to the secure holding category.

If I remove GroupB from the topic… Then when I schedule the post to appear in the GroupB area – They won’t have permissions to access!

Also - I have removed the Groups and just tried to publish… and the time passes - and the topic/category don’t move from the holding category - to the selected publish category. They just stay in the holding category.

Please help!

Thank you!

1 Like

Replying to this - perhaps to bring it to the top of your feed. It would be great if someone could help.

Thank you!


I’m not quite following the problem. What I think you want to do is initially publish the topic in a private category, for example, your site’s staff category. After creating the topic in the staff category, click the topic’s admin wrench button and select “Set Topic Timer” from the menu. On the topic timer modal, select “Schedule Publishing.” Select the category that your GroupB has access to from the “Publish To” drop down menu. Select a date from the menu, or select the “Custom date and time” option and enter a date-time of your choosing. Here’s an example from my site:

After clicking the “Set Timer” button, the topic should get published to your chosen category at the time you have set.


I also don’t understand this question.

All you are doing by “publishing” is editing the category of the topic. So as long as the category permissions are set up correctly, here’s what happens:

  • when the timer fires :stopwatch:, change the category of the topic from Foo :large_blue_circle: to Bar :red_circle:

That’s it. That’s all that is happening.


Thank you for the replies. Let me explain this in more detail.

We have a class of students. We will call them “MarchStudents”

We have a category called “MarchClass” where we are posting new project categories to. e.g. “MarchClassProject1”, “MarchClassProject2” etc.

I have created a group called “MarchStudents” - and have given them access to the “MarchClass”

The goal = Publish “MarchClassProject1” on March 1. Publish “MarchClassProject2” on March 5. Etc.

What I understood - > and tried to do…
For Category = “MarchClassProject1” - I want to put that in a private holding category called “Staff Only” (or whatever). → Then use the timer and set this to publish to “MarchClass” on March 1.

The Problem
If “MarchClassProject1” doesn’t have permissions for “MarchStudents” → then when I set the timer for publishing this to “MarchClass” - it doesn’t work. (presumably because “MarchClass” doesn’t have permissions for the subcategory… Which is the message I get if I try to move it manually).

I also can not give permissions for the “MarchStudents” for the “MarchClassProject1” - because if I do - it won’t let me put it in the private holding category.

1 Like

So why not create a new group that only the publishing user is a member of which has access to both? More than one group can have permissions on a single category, your response details posts and categories but really needs to explain the users and groups in play here if we’re going to be able to hand-hold you any further.

1 Like

I’m an admin - so I have permissions for both groups. This does not seem to be the issue.

“MarchStudents” – the is the group of students that needs to have access to the “MarchClassProject1” post → But not until March 1st.

If I give them permissions now → Then I can’t put in “StaffOnly” category.

If I don’t give them permissions → Then I can’t move that post to a category that is limited to “MarchStudents”

What am I missing?