Issues with using keyboard shortcut to select post to edit

Thanks for the pointer!

I happen to have a find-as-you-type extension installed that apparently blocks that functionality, so that doesn’t work for me, but it would have been nice.

As a sidenote, in Jira I get the find-as-you-type behavior and the intended effect of keyboard shortcuts.

Is the “find-as-yout-type” the standard Firefox one or is it a custom extension?

Are the Jira shortcuts key combos or simple keys like us?

Don’t you have a shortcut to switch “find-as-yout-type” on and off?

1 Like

I’m in Chrome, Ubuntu. I got the extension years ago from the marketplace (and I love it). It’s called Type-ahead-find.

Simple keys. In a list of issues it’s j/k to go forward/back, e to edit, l (lower-case L) to edit labels, c to create, …

In looking at the docs (which I haven’t done in literally years) it seems that I can blacklist sites. So… I’ve blacklisted and reloaded the window and it still has no effect (with nothing in the console). I’ll try restarting the browser…

1 Like

…aaaand still nothing.


As a followup, it seems that f (bookmark) works, but e does not.

e is working for me in Chrome/Windows; did you have a post selected? I can’t think of any reason f bookmark would work when edit would not though.

The custom browser extension captures the keyboard event and prevent it from popping to us.

1 Like

Doesn’t this feature already exist in Chrome? Press ctrl+f and type to match. I am unclear why an extension would be needed?

(you may need to press this twice in long Discourse topics as we do capture that because on a long topic only the visible posts will be loaded.)


To be clear, I’ve blacklisted the forum in the find-as-you-type extension, so it’s no longer blocking anything - if it ever was; as I said, the keyboard shortcuts work in Jira.

Could you elaborate on post selection, please? Once I open a topic, it’s not clear to me how I “select” an individual post in it. I’ve tried clicking in the post, but that doesn’t seem to select it.

Per the above ↑

Wow! It seems the only way to “select” a post is to “browse” to it using j/k. If I click a post a dozen times it does nothing. It’s only when I use the keyboard that the red selection indicator is added to the interface! Since I wasn’t aware of the keyboard shortcuts it never occurred to me to use the keyboard in this interface. I’ve never seen the red selection indicator before just now.

May I suggest that this facet of the UX be reconsidered?

I believe that sort of keyboard selection mechanism is fairly standard for advanced keyboard UIs on the web.

1 Like

I’m coming back to this because the UI continues to surprise.

I’m scrolled to the bottom of the first/only post in a thread. I want to edit it. My hands are on the keyboard, so I hit ‘j’ to select it and the first post in the list of ‘other topics’ gets the red border instead. So… in some implicit yet unusable way, the thread post was already selected?

I can’t repro, or maybe it depends how far down you’ve scrolled? Try scrolling up or down a bit more, does the behavior change?

In this recording you see me scroll to the end of the post. The buttons below aren’t even in view. Then I hit ‘j’ on the keyboard. That’s when it jumps abruptly to select the first Suggested Topic

I see so the post in question is very long. Does this happen with a more typically sized post, like this one for example?

Actually, I was quite surprised by the way that one worked. For very short posts - where I can see the buttons and a good bit of the ‘Suggested’ list on first page load, ‘j’ selects the OP. Here’s a medium-length example:

As a followup, I believe this is triggered by any amount of scrolling.

The select-first-recommended behavior happens as soon as the title is scrolled off the screen, regardless of how many screenfuls (2.5 in the example I was just looking at) the post is.