Khmer Unicode : title invalid; try to be more descriptive?


(Vannak Eng) #1

I’m trying to post a topic with this title “សាលា​ដំបូង​​​រាជ​​​ធានី​​​ចាប់​​​ផ្តើម​​​សវនាការ​​​ជុំ​​​នះ​​​ជម្រះ​​​សកម្ម​​​ជន​​​ និង​​​តំណាង​​​រាស្ត្រ​​​គណបក្ស​​​ប្រឆាំង​​​ពីបទ​​​កុបកម្ម​​​” in khmer khmer unicode. but it always shows this message.

I think that it might be because of title field doesn’t recorgnize the zwsp that is why it need more spaces.


(Jeff Atwood) #2

Did you set the language to the right value in site settings? Certain title rules are enforced differently for different languages.


(Vannak Eng) #3

what shall i do/choose as there is no Khmer km yet? Please help to advise!
Thanks…


(Jeff Atwood) #4

Try editing the site settings to turn minimum topic title length to 1 char.

Also turn off the title prettify option, since it assumes Western language.


(Vannak Eng) #5

@codinghorror Still does not work.


(Jeff Atwood) #6

I suspect there might be a catch-22 with being on a western locale. Try changing to Chinese or Japanese, then rebootstrap Discourse and try an all Unicode title.


(Vannak Eng) #7

do i need to do this to rebootstrap?

./launcher bootstrap web
./launcher destroy web
./launcher start web

(Sam Saffron) #8

no you do not need to rebootstrap, you can change locale directly from the site settings


(Vannak Eng) #9

@sam I did change in setting but still no hope. anyway, any plan to add km local to discourse?


(Sam Saffron) #10

sure, if you translate it


(Vannak Eng) #11

I have finished around 200 strings will speed up for that. :slight_smile:


(Vannak Eng) #12

as my observation, it needs at least for spaces to be more descriptive.


(Marcin Rataj) #13

Hm… four spaces produces five ‘words’.
Perhaps a word count impacts calculating ‘title min entropy’ parameter?


(Vannak Eng) #14

i did try that but didnt work. maybe the language is complex script so it is not recornizing it?


(Sam Saffron) #15

set “max word length” to 9999

we had a very terrible name there, I fixed it

https://github.com/discourse/discourse/commit/1f59375c820c4457713963856dc517c1eba3bc0c


(Vannak Eng) #16

hmmm still not really work.


(Mittineague) #17

Broken Latin-1 text?


(Vannak Eng) #18

it just keeps asking me to put at least 4 spaces in order to have the title more descriptive.


(Vannak Eng) #19

Hi there is there anyway to fix this?

Thanks!


(Sam Saffron) #20

Did you set title max word length to 9999 ?