How to turn off a checker for "Title seems unclear, is it a complete sentence?"

faq-material

(Sung Kim) #1

Even ehought I put a title, I am getting this message:

Perhaps, it’s because I am using Korean in the title. How can I turn off the checker? I set “title min entropy” to 0, but I still get this error message.

FYI, the title I used is “r0.12 리비전 작업 진행 사항을 잠시 공유해봅니다.” (in Korean).


Topic subject letter's case not editable
Capitalized words in titles got turned into lowercase when not English
(Rafael dos Santos Silva) #2

Enable allow uppercase posts.


Turn off "Title seems unclear, is it a complete sentence?"
(Sung Kim) #3

Thanks! It works. I guess we need a better error message here. :slight_smile:


(Jay Pfaffman) #4

@codinghorror, perhaps this should be in the startup wizard if a language with this problem is selected.


(David Hagar) #9

I find this to be an extremely annoying feature as well. I cannot figure out how to turn it off. I don’t want to enable “All Caps” in posts, but I also think something like “To Forum or Not to Forum” is understandable for my community, but that is not allowed. The technology used does not seem to work very well and, honestly, I would like to control what I set a topic as - even if the software doesn’t like it.


(Jeff Atwood) #10

This is an allowed topic title, so I am not sure what you mean? You can test on try.discourse.org if needed.


(David Hagar) #11

I don’t know what to tell you. I had to change the min entropy setting from 10 to 5 to get it to accept it.


(Jeff Atwood) #12

Try adding a question mark. That’s a rather extreme edge case, the palindrome of topic titles…


(Christoph) #13

But at least you found out how to turn it off, right?


(David Hagar) #14

Yes :slight_smile:. Thank you all for the help.


(Stephen Chung) #15

Suggest modification:

If title has >50% letters which are non-ASCII (and non-ASCII Latin Extended, which basically means code point > 255)…

Turn off rules related to English (e.g. complete sentence, all-caps etc.)

Because under such circumstances, it is highly likely that:

  1. The title is not in English
  2. The English letters used in the title are probably ID’s, model numbers, codes (e.g. stock code), abbrev, prefix, etc. that should be left as-is
  3. Applying English styling rules is a mistake

This can be simply done by:

  1. Define non-english if (ch > 255) / (Latin letters total count) > 1
  2. Do not apply prettify on non-english
  3. Do not apply seems_quiet on non-english
  4. Do not apply seems_pronounceable and seems_unpretentious on non-english because their punctuation may not be in the ASCII set (e.g. CJK punctuation are all > 255)

(Jeff Atwood) #16

Why bother with all that? Just enable the site setting as specified. If you feel that is worth doing, submit a pull request.


(Stephen Chung) #17

Well, I suppose there are mix-language forums out there.

For example, the forum I’m building is wordwide and is roughly 1/4 English, 1/4 European languages, and 1/2 Chinese.

Just turning off all the TextSentinel goodies will lose it on one half of all the content where it would have made sense.


#18

I have enabled suggested “allow uppercase posts” setting but Discourse still prevents me from create a new post with titles like “Исключение TransientPropertyValueException” (where “Исключение” is “exception” in Russian).
How to switch off this “cleaver” (read “very annoying”) logic?


(Andrew Schleifer) #19

I’m not sure, Wally. Have you tried the suggestion above?


#20

sure, Wally
image


(Ivan Rapekas) #22

Hi, @Shrike, I think the allowable word lenght should be >30. Look at the title max word length setting. I use 60 in my forum for java developers😉


#23

Thanks! I’ve increased it as well.