Language Changed to Japanese for multiple users


#1

This morning I noticed that the interface had changed to Japanese and I had no idea how to change it back. I assumed I must have somehow pocket switched it on my phone, but then others told me the same thing happened to them. It self corrected within a few minutes, but we are still a little concerned. Is there a way to find out how this happened?


Default locale has stopped working
We're seeing random Japanese characters
#2

I just had report of this as well. I’m gathering details.


(Jeff Atwood) #3

We think this is related to changes @fantasticfears made to allow site settings to be locale specific. It looks like we we will have to roll that back.

cc @sam


(Alex Sherwood) #4

We’ve had quite a few users (including myself) report the issue -

for me, the language selection seems to be random, I’ve had it switch to other languages too. I’m not using a VPN.


#5

It’s definitely happening to us over in the WaniKani forums. In fact, some of us are pretty confused as to why it’s happening - doesn’t seem to have to do with region… maybe IMEs that are installed (a few of us have gotten Japanese), but others have gotten Finnish and Korean… No VPNs, no Finnish language pack…


(Seth Godin) #6

it seems to be getting worse, in that the entire interface has now changed for me.


(Sam Saffron) #7

We are on it, will have it resolved very soon


(Seth Godin) #8

thanks @sam

you guys are astounding. it’s appreciated.


#9

A post was split to a new topic: Setting up Avatar Flair


(Erick Guan) #10

I couldn’t imagine why it’s crashing but I noticed allow_user_locale is on for reported sites as well as set_locale_from_accept_language_header. Maybe related settings’ types are changed to what is supposed to be but failing to be detecting by the validators. cc @sam


(Joffrey Jaffeux) #11

I suspected the same, but couldn’t reproduce the issue locally with those settings.


(Erick Guan) #12

SiteSettings::TypeSupervisor merely flips some string type in DB to new types like email, username. So I think it’s not related.

The interface for logined user comes from current_user.effective_locale and passes through application view. The value shouldn’t be bumpy. Does the faulty instance get changed for their SiteSetting.default_locale?


(Alan Tan) #13

This is fixed in

and deployed to all of our hosted customers.


(Jeff Atwood) #14